summaryrefslogtreecommitdiffstats
path: root/Tests/Qt4Targets/IncrementalMoc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Qt4Targets/IncrementalMoc/CMakeLists.txt')
-rw-r--r--Tests/Qt4Targets/IncrementalMoc/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/Qt4Targets/IncrementalMoc/CMakeLists.txt b/Tests/Qt4Targets/IncrementalMoc/CMakeLists.txt
new file mode 100644
index 0000000..4ba0ced
--- /dev/null
+++ b/Tests/Qt4Targets/IncrementalMoc/CMakeLists.txt
@@ -0,0 +1,13 @@
+
+cmake_minimum_required(VERSION 2.8.12)
+project(IncrementalMoc)
+
+find_package(Qt4 REQUIRED)
+
+qt4_generate_moc(foo.h moc_foo.cpp)
+
+add_library(testlib foo.cpp moc_foo.cpp)
+target_link_libraries(testlib Qt4::QtCore)
+if (ADD_DEF)
+ target_compile_definitions(testlib PRIVATE NEW_DEF)
+endif()