summaryrefslogtreecommitdiffstats
path: root/Tests/Server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Server/CMakeLists.txt')
-rw-r--r--Tests/Server/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/Tests/Server/CMakeLists.txt b/Tests/Server/CMakeLists.txt
new file mode 100644
index 0000000..41d1131
--- /dev/null
+++ b/Tests/Server/CMakeLists.txt
@@ -0,0 +1,28 @@
+cmake_minimum_required(VERSION 3.4)
+project(Server CXX)
+
+find_package(PythonInterp REQUIRED)
+
+macro(do_test bsname file type)
+ execute_process(COMMAND ${PYTHON_EXECUTABLE}
+ -B # no .pyc files
+ "${CMAKE_SOURCE_DIR}/${type}-test.py"
+ "${CMAKE_COMMAND}"
+ "${CMAKE_SOURCE_DIR}/${file}"
+ "${CMAKE_SOURCE_DIR}"
+ "${CMAKE_BINARY_DIR}"
+ "${CMAKE_GENERATOR}"
+ RESULT_VARIABLE test_result
+ )
+
+ if (NOT test_result EQUAL 0)
+ message(SEND_ERROR "TEST FAILED: ${test_result}")
+ endif()
+endmacro()
+
+do_test("test_cache" "tc_cache.json" "server")
+do_test("test_handshake" "tc_handshake.json" "server")
+do_test("test_globalSettings" "tc_globalSettings.json" "server")
+do_test("test_buildsystem1" "tc_buildsystem1.json" "server")
+
+add_executable(Server empty.cpp)