summaryrefslogtreecommitdiffstats
path: root/Tests/SourcesProperty/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/SourcesProperty/CMakeLists.txt')
-rw-r--r--Tests/SourcesProperty/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/SourcesProperty/CMakeLists.txt b/Tests/SourcesProperty/CMakeLists.txt
new file mode 100644
index 0000000..6c99e00
--- /dev/null
+++ b/Tests/SourcesProperty/CMakeLists.txt
@@ -0,0 +1,12 @@
+
+cmake_minimum_required(VERSION 3.0)
+
+project(SourcesProperty)
+
+add_library(iface INTERFACE)
+set_property(TARGET iface PROPERTY INTERFACE_SOURCES iface.cpp)
+
+add_executable(SourcesProperty main.cpp)
+target_link_libraries(SourcesProperty iface)
+
+set_property(TARGET SourcesProperty APPEND PROPERTY SOURCES prop.cpp)