summaryrefslogtreecommitdiffstats
path: root/Tests/Testing/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/Testing/CMakeLists.txt')
-rw-r--r--Tests/Testing/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/Testing/CMakeLists.txt b/Tests/Testing/CMakeLists.txt
index 87953ba..3c2dd97 100644
--- a/Tests/Testing/CMakeLists.txt
+++ b/Tests/Testing/CMakeLists.txt
@@ -37,6 +37,12 @@ FIND_LIBRARY(CMAKE_LIB
LINK_LIBRARIES(${CMAKE_LIB})
#
+# Include Dart
+# (will also set NSLOOKUP, HOSTNAME, etc.)
+#
+INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
+
+#
# Extra coverage
#
BUILD_COMMAND(BUILD_COMMAND_VAR ${CMAKE_MAKE_PROGRAM})
@@ -54,3 +60,8 @@ ENABLE_TESTING()
ADD_EXECUTABLE(testing testing.cxx)
ADD_TEST(testing ${Testing_BINARY_DIR}/bin/testing)
+#
+# Force subdirs
+# (coverage)
+#
+SUBDIRS(sub1)