summaryrefslogtreecommitdiffstats
path: root/Tests/UseSWIG/LegacyPython/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/UseSWIG/LegacyPython/CMakeLists.txt')
-rw-r--r--Tests/UseSWIG/LegacyPython/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/UseSWIG/LegacyPython/CMakeLists.txt b/Tests/UseSWIG/LegacyPython/CMakeLists.txt
new file mode 100644
index 0000000..11a0d28
--- /dev/null
+++ b/Tests/UseSWIG/LegacyPython/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.1)
+
+project(TestLegacyPython CXX)
+
+include(CTest)
+
+set(language "python")
+
+include (../LegacyConfiguration.cmake)
+
+add_test (NAME LegacyPython
+ COMMAND "${CMAKE_COMMAND}" -E env "PYTHONPATH=$<TARGET_FILE_DIR:${SWIG_MODULE_example_REAL_NAME}>"
+ "${PYTHON_EXECUTABLE}" "${CMAKE_CURRENT_SOURCE_DIR}/../runme.py")