summaryrefslogtreecommitdiffstats
path: root/Tests/VSGNUFortran/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/VSGNUFortran/CMakeLists.txt')
-rw-r--r--Tests/VSGNUFortran/CMakeLists.txt19
1 files changed, 2 insertions, 17 deletions
diff --git a/Tests/VSGNUFortran/CMakeLists.txt b/Tests/VSGNUFortran/CMakeLists.txt
index 422350a..229c315 100644
--- a/Tests/VSGNUFortran/CMakeLists.txt
+++ b/Tests/VSGNUFortran/CMakeLists.txt
@@ -17,23 +17,8 @@ if(CMAKE_CONFIGURATION_TYPES)
endforeach()
endif()
-include(CMakeAddFortranSubdirectory)
-# add the fortran subdirectory as a fortran project
-# the subdir is fortran, the project is FortranHello
-cmake_add_fortran_subdirectory(fortran
- PROJECT FortranHello # project name in toplevel CMakeLists.txt
- ARCHIVE_DIR ${CMAKE_ARCHIVE_OUTPUT_DIRECTORY}
- RUNTIME_DIR bin # ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}
- LIBRARIES hello world # target libraries created
- CMAKE_COMMAND_LINE
- -DCMAKE_RUNTIME_OUTPUT_DIRECTORY=${CMAKE_RUNTIME_OUTPUT_DIRECTORY}
- -DCMAKE_ARCHIVE_OUTPUT_DIRECTORY=${CMAKE_ARCHIVE_OUTPUT_DIRECTORY}
- -DCMAKE_LIBRARY_OUTPUT_DIRECTORY=${CMAKE_LIBRARY_OUTPUT_DIRECTORY}
- LINK_LIBRARIES # link interface libraries
- LINK_LIBS hello world # hello needs world to link
- )
-
-include_directories(${VSGNUFortran_BINARY_DIR}/fortran)
+add_subdirectory(subdir)
+include_directories(${VSGNUFortran_BINARY_DIR}/subdir/fortran)
add_subdirectory(c_code)
# use a cmake script to run the executable so that PATH
# can be set with the MinGW/bin in it, and the fortran