summaryrefslogtreecommitdiffstats
path: root/Utilities/Release/Cygwin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Utilities/Release/Cygwin/CMakeLists.txt')
-rw-r--r--Utilities/Release/Cygwin/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Utilities/Release/Cygwin/CMakeLists.txt b/Utilities/Release/Cygwin/CMakeLists.txt
index 0c274f3..2420c97 100644
--- a/Utilities/Release/Cygwin/CMakeLists.txt
+++ b/Utilities/Release/Cygwin/CMakeLists.txt
@@ -1,8 +1,8 @@
-FILE(GLOB INSTALLED_CURSES /usr/bin/cygncurses*.dll)
+FILE(GLOB INSTALLED_CURSES /usr/bin/cygncurses-*.dll)
SET(MAX 0)
FOREACH(f ${INSTALLED_CURSES})
IF(NOT "${f}" MATCHES "\\+")
- STRING(REGEX REPLACE ".*([0-9]).dll" "\\1" NUMBER "${f}")
+ STRING(REGEX REPLACE ".*-([0-9]*).dll" "\\1" NUMBER "${f}")
IF(NUMBER GREATER MAX)
SET(MAX ${NUMBER})
ENDIF(NUMBER GREATER MAX)