summaryrefslogtreecommitdiffstats
path: root/Utilities/cmcurl-7.19.0/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Utilities/cmcurl-7.19.0/lib/CMakeLists.txt')
-rw-r--r--Utilities/cmcurl-7.19.0/lib/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/Utilities/cmcurl-7.19.0/lib/CMakeLists.txt b/Utilities/cmcurl-7.19.0/lib/CMakeLists.txt
index 8275d47..740d4d9 100644
--- a/Utilities/cmcurl-7.19.0/lib/CMakeLists.txt
+++ b/Utilities/cmcurl-7.19.0/lib/CMakeLists.txt
@@ -16,7 +16,7 @@ endif(CMAKE_CROSSCOMPILING)
set(libCurl_SRCS
- file.c timeval.c base64.c hostip.c progress.c formdata.c
+ file.c timeval.c base64.c hostip.c progress.c formdata.c
cookie.c http.c sendf.c ftp.c url.c dict.c if2ip.c speedcheck.c
ldap.c ssluse.c version.c getenv.c escape.c mprintf.c telnet.c
netrc.c getinfo.c transfer.c strequal.c easy.c security.c krb4.c
@@ -26,13 +26,13 @@ set(libCurl_SRCS
hostares.c hostasyn.c hostip4.c hostip6.c hostsyn.c hostthre.c
inet_ntop.c parsedate.c select.c gtls.c sslgen.c tftp.c splay.c
strdup.c socks.c ssh.c nss.c qssl.c
- arpa_telnet.h netrc.h file.h timeval.h qssl.h hostip.h
+ arpa_telnet.h netrc.h file.h timeval.h qssl.h hostip.h
progress.h formdata.h cookie.h http.h sendf.h ftp.h url.h dict.h
if2ip.h speedcheck.h urldata.h curl_ldap.h ssluse.h escape.h telnet.h
getinfo.h strequal.h krb4.h memdebug.h inet_ntoa_r.h http_chunks.h
strtok.h connect.h llist.h hash.h content_encoding.h share.h
curl_md5.h http_digest.h http_negotiate.h http_ntlm.h inet_pton.h
- strtoofft.h strerror.h inet_ntop.h curlx.h memory.h setup.h
+ strtoofft.h strerror.h inet_ntop.h curlx.h memory.h setup.h
transfer.h select.h easyif.h multiif.h parsedate.h sslgen.h gtls.h
tftp.h sockaddr.h splay.h strdup.h setup_once.h socks.h ssh.h nssg.h
curl_base64.h
@@ -561,6 +561,9 @@ endif(WIN32)
configure_file(${CURL_SOURCE_DIR}/lib/config.cmake.h.in
${CURL_BINARY_DIR}/lib/config.h)
+set(CURL_SIZEOF_LONG ${SIZEOF_LONG})
+configure_file(${CURL_SOURCE_DIR}/include/curl/curlbuild.cmake.h.in
+ ${CURL_BINARY_DIR}/include/curl/configbuild.h)
add_library(cmcurl ${libCurl_SRCS})
target_link_libraries(cmcurl ${CURL_LIBS})