summaryrefslogtreecommitdiffstats
path: root/Utilities/cmjsoncpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Utilities/cmjsoncpp/CMakeLists.txt')
-rw-r--r--Utilities/cmjsoncpp/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/Utilities/cmjsoncpp/CMakeLists.txt b/Utilities/cmjsoncpp/CMakeLists.txt
new file mode 100644
index 0000000..ef370cc
--- /dev/null
+++ b/Utilities/cmjsoncpp/CMakeLists.txt
@@ -0,0 +1,25 @@
+project(JsonCpp CXX)
+
+# Disable warnings to avoid changing 3rd party code.
+if(CMAKE_CXX_COMPILER_ID MATCHES
+ "^(GNU|Clang|AppleClang|XL|VisualAge|SunPro|MIPSpro|HP|Intel)$")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -w")
+elseif(CMAKE_CXX_COMPILER_ID STREQUAL "PathScale")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -woffall")
+endif()
+
+set(JSONCPP_SOURCES
+ src/lib_json/json_reader.cpp
+ src/lib_json/json_tool.h
+ src/lib_json/json_value.cpp
+ src/lib_json/json_writer.cpp
+ )
+
+include_directories(
+ ${JsonCpp_SOURCE_DIR}/include
+ ${KWSYS_HEADER_ROOT}
+ )
+
+add_library(cmjsoncpp ${JSONCPP_SOURCES})
+target_link_libraries(cmjsoncpp ${CMake_KWIML_LIBRARIES})
+set_property(TARGET cmjsoncpp PROPERTY CXX_INCLUDE_WHAT_YOU_USE "")