summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8478af2..21c772a 100644
--- a/configure.in
+++ b/configure.in
@@ -93,7 +93,7 @@ fi
AC_SUBST(CMAKE_ANSI_CFLAGS)
AC_SUBST(CMAKE_ANSI_CXXFLAGS)
-# check no g++ compilers to see if they have the standard
+# check non-g++ compilers to see if they have the standard
# ansi stream files (without the .h)
if test $ac_cv_prog_gxx = no; then
AC_MSG_CHECKING( ansi standard C++ stream headers )
@@ -109,6 +109,21 @@ if test $ac_cv_prog_gxx = no; then
fi
fi
+# check non-g++ compilers to see if they have std::stringstream
+if test $ac_cv_prog_gxx = no; then
+ AC_MSG_CHECKING( for ansi standard C++ stringstream )
+ rm -rf conftest.*
+ cat > conftest.cc <<!
+#include <sstream>
+!
+ if test -z "`${CXX} $CMAKE_ANSI_CXXFLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ echo "$ac_t""yes" 1>&6
+ else
+ AC_DEFINE(CMAKE_NO_ANSI_STRING_STREAM)
+ echo "$ac_t""no" 1>&6
+ fi
+fi
+
# check to see if stl is in the std namespace
if test $ac_cv_prog_gxx = no; then
AC_MSG_CHECKING( ansi standard namespace support )