| Commit message (Collapse) | Author | Age | Files | Lines |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Since macOS 12.0, the ``hdiutil udifrez`` and ``hdiutil udifderez``
commands to embed and extract resources in a disk image are deprecated.
The CPack DragNDrop Generator uses these to attach the SLA specified by
the `CPACK_RESOURCE_FILE_LICENSE` option. Since that option is shared
by multiple CPack generators, we cannot deprecate it. Instead, add an
explicit option to control the behavior. This will give projects a way
to package on future macOS versions that remove the commands.
In order to provide a long-term transition away from attaching SLAs to
disk images, update `cpack` to default this behavior to OFF. To retain
compatibility for CMake projects, teach the CPack module to default the
option to ON. Later a policy can be added to change the default.
Issue: #22978
|
|
|
|
|
|
|
|
|
| |
The domains element determines the required authorization level needed
for the install. The auth attribute of the pkg-ref element has been
deprecated in favor of domains, so if the domains options are
specified, the auth attribute is omitted.
Fixes: #23030
|
|
|
|
|
|
|
|
|
|
| |
- mismatched comments and code,
- remove superfluous log of the "Real package" (which can
still change! log the changed filename if it does),
- the "fix up the package name" code was replacing the
pkg 1.17 suffix by the pkg 1.17 suffix, so it wasn't
really being useful. Whether **any** of the backwards-
compatibility packaging code is useful is another thing.
|
| |
|
|
|
|
|
|
|
|
|
| |
When using libpkg, the output filename is determined by libpkg
itself, based on information in the manifest: package name and
version, basically. This doesn't necessarily match the name that
CMake has determined via CPACK_TEMPORARY_PACKAGE_FILE_NAME or
CPACK_PACKAGE_FILE_NAME. So reset the CMake-determined list
to match what libpkg will do.
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
The pkg_create_from_manifest() function was never really intended as
stable API, and bapt@ has asked me to stop using it so the public
API can be stabilized.
Port to pkg_create() with its attendant settings struct.
Since we already have a complete manifest file, we can hand
that (including the embedded plist) to pkg_create().
While here, reintroduce pkg_init(), which lived in downstream patches
for a while and then went away again.
|
|\
| |
| |
| |
| |
| |
| |
| | |
e8e07a90c1 CPackIFW: add support for signing the generated app bundles on macOS
Acked-by: Kitware Robot <kwrobot@kitware.com>
Acked-by: buildbot <buildbot@kitware.com>
Merge-request: !6754
|
| |
| |
| |
| |
| |
| |
| |
| | |
Adds the CPACK_IFW_PACKAGE_SIGNING_IDENTITY CPackIFW variable.
This variable mirrors the --sign option of the binarycreator tool.
Fixes: #22927
|
| |
| |
| |
| |
| |
| |
| |
| | |
This adds a new option, CPACK_PRODUCTBUILD_IDENTIFIER, which allows
for customization of the productbuild product identifier within the
CPack productbuild generator.
Fixes: #20830
|
| |
| |
| |
| |
| |
| |
| |
| | |
This CPack generator was never documented, and has been deprecated since
commit 2ed00e8ef8 (CPack: Deprecate OSXX11 generator, 2020-01-31,
v3.17.0-rc1~45^2).
Issue: #20235
|
| | |
|
|/
|
|
| |
In applicable areas only, of course.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Adds the following CPackIFW variables:
- CPACK_IFW_ARCHIVE_FORMAT
- CPACK_IFW_ARCHIVE_COMPRESSION
These variables control mirror the --archive-format and --compression
options of the QtIFW binarycreator and repogen tools.
Fixes: #22803
Co-authored-by: Erlend E. Aasland <erlend.aasland@innova.no>
Co-authored-by: Awen Autret
|
|\
| |
| |
| |
| |
| |
| |
| | |
b7e9cd05cd Replace the only non-standard _snprintf with snprintf
5ba6e8ac59 Source: Replace most calls to sprintf with snprintf
Acked-by: Kitware Robot <kwrobot@kitware.com>
Merge-request: !6649
|
| | |
|
|/ |
|
|\
| |
| |
| |
| |
| |
| |
| |
| | |
f2f4e66f64 CPackIFW: Add support for RunProgram* config variables
Acked-by: Kitware Robot <kwrobot@kitware.com>
Acked-by: buildbot <buildbot@kitware.com>
Acked-by: Konstantin Podsvirov <konstantin@podsvirov.pro>
Merge-request: !6610
|
| |
| |
| |
| |
| |
| | |
This patch adds support for specifying <RunProgram>,
<RunProgramArguments>, and <RunProgramDescription> in the IFW
configuration file.
|
|\ \
| |/
|/|
| |
| |
| |
| | |
40e73c5ac4 Source: Fix typo in _WIN32 preprocessor checks
Acked-by: Kitware Robot <kwrobot@kitware.com>
Merge-request: !6631
|
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Since CMake's default compiler flags with MSVC include `-DWIN32` for
historical reasons, a few preprocessor conditions were accidentally
checking for `WIN32` instead of `_WIN32`. The corresponding blocks
were left out when compiling official binaries for `cmake.org` because
we hard-code compiler flags without `-DWIN32`.
Fixes: #22764
|
| |\
| | |
| | |
| | |
| | |
| | |
| | |
| | |
| | | |
f7a5f28318 cmake: Fix '-E cat' command for binary files on Windows
90b39a5209 cmConsoleBuf: Factor out cout/cerr console buffer management
f1fdd15863 clang-format: Fix include block order in ctest.cxx and cpack.cxx
Acked-by: Kitware Robot <kwrobot@kitware.com>
Merge-request: !5364
|
|\ \ \
| | | |
| | | |
| | | |
| | | |
| | | |
| | | | |
761b6e2466 CPackIFW: Avoid colliding names for icons / logos
Acked-by: Kitware Robot <kwrobot@kitware.com>
Merge-request: !6613
|
| | | |
| | | |
| | | | |
Fixes: #16515
|
| | | | |
|
|\ \ \ \
| | | | |
| | | | |
| | | | |
| | | | |
| | | | |
| | | | |
| | | | | |
09f4edbcef Fix Clang -Wbitwise-instead-of-logical warnings
Acked-by: Kitware Robot <kwrobot@kitware.com>
Acked-by: buildbot <buildbot@kitware.com>
Merge-request: !6623
|
| |/ / / |
|
|\ \ \ \
| |/ / /
|/| | |
| | | |
| | | |
| | | |
| | | |
| | | | |
ed9dbe9218 CPack/WiX: Add option to skip the WixUIExtension
Acked-by: Kitware Robot <kwrobot@kitware.com>
Acked-by: buildbot <buildbot@kitware.com>
Merge-request: !6619
|
| | | |
| | | |
| | | |
| | | | |
Fixes: #22747
|
|\ \ \ \
| | | | |
| | | | |
| | | | |
| | | | |
| | | | |
| | | | |
| | | | | |
c50329d3ed CPackIFW: Refactor cmCPackIFWGenerator::PackageFiles
Acked-by: Kitware Robot <kwrobot@kitware.com>
Acked-by: buildbot <buildbot@kitware.com>
Merge-request: !6617
|
| |/ / /
| | | |
| | | |
| | | |
| | | |
| | | |
| | | |
| | | |
| | | |
| | | |
| | | | |
Split PackageFiles() into four methods, for increased readability:
- cmCPackIFWGenerator::BuildRepogenCommand
- cmCPackIFWGenerator::BuildBinaryCreatorCommand
- cmCPackIFWGenerator::RunRepogen
- cmCPackIFWGenerator::RunBinaryCreator
Fixes: #22744
|
|\ \ \ \
| | | | |
| | | | |
| | | | |
| | | | |
| | | | |
| | | | |
| | | | | |
6d39c845ee CPackIFW: Add support for ProductImages config option
Acked-by: Kitware Robot <kwrobot@kitware.com>
Acked-by: buildbot <buildbot@kitware.com>
Merge-request: !6611
|
| |/ / / |
|
|/ / /
| | |
| | |
| | | |
Fixes: #22736
|
| | |
| | |
| | |
| | | |
Use the success/fail flag for the function return value.
|
| | | |
|
| | | |
|
| | | |
|
| | | |
|
| | |
| | |
| | |
| | |
| | |
| | |
| | | |
To avoid ambiguity on std::string assigment between the following two
cmProp cast operators:
* operator const std::string&() const noexcept
* operator cm::string_view() const noexcept
|
| | | |
|
| | |
| | |
| | |
| | |
| | |
| | | |
Also update call sites to report the error.
Issue: #19666
|
|\ \ \
| | | |
| | | |
| | | |
| | | |
| | | |
| | | | |
795e406e3b CPack/NSIS: Add option to not display license page
Acked-by: Kitware Robot <kwrobot@kitware.com>
Merge-request: !6422
|
| | | |
| | | |
| | | |
| | | | |
Fixes: #22215
|
|\ \ \ \
| | | | |
| | | | |
| | | | |
| | | | |
| | | | |
| | | | | |
c0572a15d6 CPack/NSIS: Bump minimal version of NSIS to 3.03
Acked-by: Kitware Robot <kwrobot@kitware.com>
Merge-request: !6425
|
| |/ / /
| | | |
| | | |
| | | | |
Fixes: #22508
|
|/ / / |
|
| | | |
|
| | | |
|
| | | |
|
| | |
| | |
| | |
| | | |
Also, fix incorrect `retval` accumulation.
|