From 5ead31da6341eb5a410f9f5b7b65cd5dcd8f0eae Mon Sep 17 00:00:00 2001
From: Peter Kuemmel <syntheticpp@gmx.net>
Date: Sun, 17 Jun 2012 10:14:36 +0200
Subject: Ninja: try work around for bcc32 bug

---
 Source/cmcldeps.cxx | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/Source/cmcldeps.cxx b/Source/cmcldeps.cxx
index d8bb162..374ee10 100644
--- a/Source/cmcldeps.cxx
+++ b/Source/cmcldeps.cxx
@@ -32,6 +32,10 @@
 #include <signal.h>
 #endif
 
+
+// bcc32 only finds remove(const char*)
+namespace stlport { }
+
 #if defined(_WIN64)
 typedef unsigned __int64 cmULONG_PTR;
 #else
@@ -429,8 +433,10 @@ bool SubprocessSet::DoWork() {
   subproc->OnPipeReady();
 
   if (subproc->Done()) {
+    using namespace std;
+    using namespace stlport;
     std::vector<Subprocess*>::iterator end =
-        std::remove(running_.begin(), running_.end(), subproc);
+        remove(running_.begin(), running_.end(), subproc);
     if (running_.end() != end) {
       finished_.push(subproc);
       running_.resize(end - running_.begin());
-- 
cgit v0.12