From 2694ad76c538333d3ff45613bd1201f97af003cd Mon Sep 17 00:00:00 2001
From: Bill Hoffman <bill.hoffman@kitware.com>
Date: Tue, 17 Jan 2006 09:27:43 -0500
Subject: ENH: correct standard libraries

---
 Modules/Platform/Windows-cl.cmake | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/Modules/Platform/Windows-cl.cmake b/Modules/Platform/Windows-cl.cmake
index f7d06b5..8ea450f 100644
--- a/Modules/Platform/Windows-cl.cmake
+++ b/Modules/Platform/Windows-cl.cmake
@@ -174,6 +174,8 @@ ELSE(CMAKE_COMPILER_2005)
     SET (CMAKE_C_FLAGS_RELWITHDEBINFO_INIT "/MT /Zi /O2")
     SET (CMAKE_STANDARD_LIBRARIES "kernel32.lib user32.lib gdi32.lib advapi32.lib rpcrt4.lib" CACHE STRING
       "Libraries linked by defalut with all applications.")
+    SET (CMAKE_STANDARD_LIBRARIES "kernel32.lib user32.lib gdi32.lib advapi32.lib rpcrt4.lib winspool.lib shell32.lib ole32.lib oleaut32.lib uuid.lib comdlg32.lib" CACHE STRING
+      "Libraries linked by defalut with all applications.")
   ELSE(CMAKE_USING_VC_FREE_TOOLS)
     SET(CMAKE_BUILD_TYPE_INIT Debug)
     SET (CMAKE_CXX_FLAGS_INIT "/W3 /Zm1000 /GX /GR")
-- 
cgit v0.12