From 59c408d053cfe90273db04c3804ed91d7ad59d8f Mon Sep 17 00:00:00 2001
From: Sebastian Lipponer <mail@sebastianlipponer.de>
Date: Mon, 14 Jan 2019 19:46:59 +0100
Subject: cmTargetPropertyComputer: whitelist 'MANUALLY_ADDED_DEPENDENCIES'.

---
 Help/manual/cmake-buildsystem.7.rst   | 1 +
 Source/cmTargetPropertyComputer.cxx   | 1 +
 Tests/InterfaceLibrary/CMakeLists.txt | 1 +
 3 files changed, 3 insertions(+)

diff --git a/Help/manual/cmake-buildsystem.7.rst b/Help/manual/cmake-buildsystem.7.rst
index 4fc484b..a1328f2 100644
--- a/Help/manual/cmake-buildsystem.7.rst
+++ b/Help/manual/cmake-buildsystem.7.rst
@@ -978,6 +978,7 @@ are:
 * Built-in properties matching ``COMPATIBLE_INTERFACE_*``
 * ``EXPORT_NAME``
 * ``IMPORTED``
+* ``MANUALLY_ADDED_DEPENDENCIES``
 * ``NAME``
 * Properties matching ``IMPORTED_LIBNAME_*``
 * Properties matching ``MAP_IMPORTED_CONFIG_*``
diff --git a/Source/cmTargetPropertyComputer.cxx b/Source/cmTargetPropertyComputer.cxx
index 06ce0b1..e1765ff 100644
--- a/Source/cmTargetPropertyComputer.cxx
+++ b/Source/cmTargetPropertyComputer.cxx
@@ -65,6 +65,7 @@ bool cmTargetPropertyComputer::WhiteListedInterfaceProperty(
     builtIns.insert("EXPORT_NAME");
     builtIns.insert("IMPORTED");
     builtIns.insert("IMPORTED_GLOBAL");
+    builtIns.insert("MANUALLY_ADDED_DEPENDENCIES");
     builtIns.insert("NAME");
     builtIns.insert("TYPE");
   }
diff --git a/Tests/InterfaceLibrary/CMakeLists.txt b/Tests/InterfaceLibrary/CMakeLists.txt
index 3db210a..6aae09a 100644
--- a/Tests/InterfaceLibrary/CMakeLists.txt
+++ b/Tests/InterfaceLibrary/CMakeLists.txt
@@ -31,6 +31,7 @@ add_library(item_real STATIC item.cpp)
 add_library(item_iface INTERFACE IMPORTED)
 set_property(TARGET item_iface PROPERTY IMPORTED_LIBNAME item_real)
 add_dependencies(item_iface item_real)
+get_property(item_iface_dependencies TARGET item_iface PROPERTY MANUALLY_ADDED_DEPENDENCIES)
 link_directories(${CMAKE_CURRENT_BINARY_DIR})
 
 add_executable(InterfaceLibrary definetestexe.cpp)
-- 
cgit v0.12