From 9737ea074a5e199f5785f9f242c5ec80394b229f Mon Sep 17 00:00:00 2001
From: Brad King <brad.king@kitware.com>
Date: Mon, 28 Sep 2009 11:36:17 -0400
Subject: Install third-party utility copyright notices

Some of our third-party utilities have licenses that require their
copyright and license notices to be distributed with binary forms.  This
commit adds installation rules to include these notices with installed
CMake documentation.
---
 Utilities/cmcompress/CMakeLists.txt |  2 ++
 Utilities/cmcompress/Copyright.txt  | 34 ++++++++++++++++++++++++++++++++++
 Utilities/cmcurl/CMakeLists.txt     |  1 +
 Utilities/cmcurl/COPYING            | 21 +++++++++++++++++++++
 Utilities/cmcurl/curl.copyright     | 25 -------------------------
 Utilities/cmexpat/CMakeLists.txt    |  1 +
 Utilities/cmtar/CMakeLists.txt      |  2 ++
 Utilities/cmzlib/CMakeLists.txt     |  2 ++
 Utilities/cmzlib/Copyright.txt      | 23 +++++++++++++++++++++++
 9 files changed, 86 insertions(+), 25 deletions(-)
 create mode 100644 Utilities/cmcompress/Copyright.txt
 create mode 100644 Utilities/cmcurl/COPYING
 delete mode 100644 Utilities/cmcurl/curl.copyright
 create mode 100644 Utilities/cmzlib/Copyright.txt

diff --git a/Utilities/cmcompress/CMakeLists.txt b/Utilities/cmcompress/CMakeLists.txt
index f7aacfe..3323dcd 100644
--- a/Utilities/cmcompress/CMakeLists.txt
+++ b/Utilities/cmcompress/CMakeLists.txt
@@ -1,3 +1,5 @@
 PROJECT(CMCompress)
 
 ADD_LIBRARY(cmcompress cmcompress.c)
+
+INSTALL(FILES Copyright.txt DESTINATION ${CMake_DOC_DEST}/cmcompress)
diff --git a/Utilities/cmcompress/Copyright.txt b/Utilities/cmcompress/Copyright.txt
new file mode 100644
index 0000000..162332f
--- /dev/null
+++ b/Utilities/cmcompress/Copyright.txt
@@ -0,0 +1,34 @@
+Copyright (c) 1985, 1986 The Regents of the University of California.
+All rights reserved.
+
+This code is derived from software contributed to Berkeley by
+James A. Woods, derived from original work by Spencer Thomas
+and Joseph Orost.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+1. Redistributions of source code must retain the above copyright
+   notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+   notice, this list of conditions and the following disclaimer in the
+   documentation and/or other materials provided with the distribution.
+3. All advertising materials mentioning features or use of this software
+   must display the following acknowledgement:
+     This product includes software developed by the University of
+     California, Berkeley and its contributors.
+4. Neither the name of the University nor the names of its contributors
+   may be used to endorse or promote products derived from this software
+   without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+SUCH DAMAGE.
diff --git a/Utilities/cmcurl/CMakeLists.txt b/Utilities/cmcurl/CMakeLists.txt
index 8782458..e2c64db 100644
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
@@ -746,3 +746,4 @@ ENDIF(CURL_TESTING)
 ADD_EXECUTABLE(LIBCURL Testing/curltest.c)
 TARGET_LINK_LIBRARIES(LIBCURL cmcurl ${CMAKE_DL_LIBS})
 ADD_TEST(curl "${EXECUTABLE_OUTPUT_PATH}/LIBCURL")
+INSTALL(FILES COPYING DESTINATION ${CMake_DOC_DEST}/cmcurl)
diff --git a/Utilities/cmcurl/COPYING b/Utilities/cmcurl/COPYING
new file mode 100644
index 0000000..048cf56
--- /dev/null
+++ b/Utilities/cmcurl/COPYING
@@ -0,0 +1,21 @@
+COPYRIGHT AND PERMISSION NOTICE
+
+Copyright (c) 1996 - 2009, Daniel Stenberg, <daniel@haxx.se>.
+
+All rights reserved.
+
+Permission to use, copy, modify, and distribute this software for any purpose
+with or without fee is hereby granted, provided that the above copyright
+notice and this permission notice appear in all copies.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN
+NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
+DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
+OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
+OR OTHER DEALINGS IN THE SOFTWARE.
+
+Except as contained in this notice, the name of a copyright holder shall not
+be used in advertising or otherwise to promote the sale, use or other dealings
+in this Software without prior written authorization of the copyright holder.
diff --git a/Utilities/cmcurl/curl.copyright b/Utilities/cmcurl/curl.copyright
deleted file mode 100644
index 768438e..0000000
--- a/Utilities/cmcurl/curl.copyright
+++ /dev/null
@@ -1,25 +0,0 @@
-This package was cmakified by Andy Cedilnik <andy . cedilnik @ kitware.com> 
-
-It was downloaded from http://curl.haxx.se
-
-COPYRIGHT AND PERMISSION NOTICE
-
-Copyright (c) 1996 - 2007, Daniel Stenberg, <daniel@haxx.se>.
-
-All rights reserved.
-
-Permission to use, copy, modify, and distribute this software for any purpose
-with or without fee is hereby granted, provided that the above copyright
-notice and this permission notice appear in all copies.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN
-NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
-DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
-OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
-OR OTHER DEALINGS IN THE SOFTWARE.
-
-Except as contained in this notice, the name of a copyright holder shall not
-be used in advertising or otherwise to promote the sale, use or other dealings
-in this Software without prior written authorization of the copyright holder.
diff --git a/Utilities/cmexpat/CMakeLists.txt b/Utilities/cmexpat/CMakeLists.txt
index e10888d..7dd8329 100644
--- a/Utilities/cmexpat/CMakeLists.txt
+++ b/Utilities/cmexpat/CMakeLists.txt
@@ -32,3 +32,4 @@ CONFIGURE_FILE(${CMEXPAT_SOURCE_DIR}/expat.h
                ${CMEXPAT_BINARY_DIR}/expat.h)
 
 ADD_LIBRARY(cmexpat ${expat_SRCS})
+INSTALL(FILES COPYING DESTINATION ${CMake_DOC_DEST}/cmexpat)
diff --git a/Utilities/cmtar/CMakeLists.txt b/Utilities/cmtar/CMakeLists.txt
index b8e5118..8b03a17 100644
--- a/Utilities/cmtar/CMakeLists.txt
+++ b/Utilities/cmtar/CMakeLists.txt
@@ -392,3 +392,5 @@ CONFIGURE_FILE(${LIBTAR_SOURCE_DIR}/config.h.in
 ADD_LIBRARY(cmtar STATIC ${libtar_SRC})
 ADD_EXECUTABLE(tartest libtar.c)
 TARGET_LINK_LIBRARIES(tartest cmtar ${CMTAR_ZLIB_LIBRARIES})
+
+INSTALL(FILES COPYRIGHT DESTINATION ${CMake_DOC_DEST}/cmtar)
diff --git a/Utilities/cmzlib/CMakeLists.txt b/Utilities/cmzlib/CMakeLists.txt
index fdbd9ed..5ee43e3 100644
--- a/Utilities/cmzlib/CMakeLists.txt
+++ b/Utilities/cmzlib/CMakeLists.txt
@@ -42,3 +42,5 @@ ENDFOREACH(name)
 
 
 ADD_LIBRARY(cmzlib ${ZLIB_SRCS})
+
+INSTALL(FILES Copyright.txt DESTINATION ${CMake_DOC_DEST}/cmzlib)
diff --git a/Utilities/cmzlib/Copyright.txt b/Utilities/cmzlib/Copyright.txt
new file mode 100644
index 0000000..db0beae
--- /dev/null
+++ b/Utilities/cmzlib/Copyright.txt
@@ -0,0 +1,23 @@
+'zlib' general purpose compression library
+version 1.2.3, July 18th, 2005
+
+Copyright (C) 1995-2005 Jean-loup Gailly and Mark Adler
+
+This software is provided 'as-is', without any express or implied
+warranty.  In no event will the authors be held liable for any damages
+arising from the use of this software.
+
+Permission is granted to anyone to use this software for any purpose,
+including commercial applications, and to alter it and redistribute it
+freely, subject to the following restrictions:
+
+1. The origin of this software must not be misrepresented; you must not
+   claim that you wrote the original software. If you use this software
+   in a product, an acknowledgment in the product documentation would be
+   appreciated but is not required.
+2. Altered source versions must be plainly marked as such, and must not be
+   misrepresented as being the original software.
+3. This notice may not be removed or altered from any source distribution.
+
+Jean-loup Gailly        Mark Adler
+jloup@gzip.org          madler@alumni.caltech.edu
-- 
cgit v0.12