summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-01-07 15:59:48 (GMT)
committerBrad King <brad.king@kitware.com>2014-02-14 20:48:40 (GMT)
commit5698edde9f74dafce2265c2dcc23d9f62f36cbc1 (patch)
tree49155a199af8ddb91beec9ea4af5b47c2f207bc0 /src/CMakeLists.txt
parent6d1be125bdc0f004717eb6dff1c33a8ad8816a3c (diff)
downloadCastXML-5698edde9f74dafce2265c2dcc23d9f62f36cbc1.zip
CastXML-5698edde9f74dafce2265c2dcc23d9f62f36cbc1.tar.gz
CastXML-5698edde9f74dafce2265c2dcc23d9f62f36cbc1.tar.bz2
Add castxml executable
Load command line arguments through KWSys Encoding. Install the executable to 'bin/castxml'.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..e12bf45
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,21 @@
+#=============================================================================
+# Copyright Kitware, Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#=============================================================================
+
+add_executable(castxml castxml.cxx)
+target_link_libraries(castxml
+ cxsys
+ )
+install(TARGETS castxml DESTINATION bin)