summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <dimitri@stack.nl>2015-05-17 09:58:27 (GMT)
committerDimitri van Heesch <dimitri@stack.nl>2015-05-17 09:58:27 (GMT)
commit7bcf8e9a379ec0599160e5562f07b93f8fb9557a (patch)
tree6b8eea084053c1d891b3c9a5c1e993203902718a /CMakeLists.txt
parent2e39e5c7c1427ac6b24c64b7ef01be8d5a20092b (diff)
downloadDoxygen-7bcf8e9a379ec0599160e5562f07b93f8fb9557a.zip
Doxygen-7bcf8e9a379ec0599160e5562f07b93f8fb9557a.tar.gz
Doxygen-7bcf8e9a379ec0599160e5562f07b93f8fb9557a.tar.bz2
Removed old build files, added install targets and other options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 18 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b412c43..616b406 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,8 +18,10 @@ option(build_wizard "Build the GUI frontend for doxygen." OFF)
option(build_app "Example showing how to embed doxygen in an application." OFF)
option(build_xmlparser "Example showing how to parse doxygen's XML output." OFF)
option(build_search "Build external search tools (doxysearch and doxyindexer)" OFF)
+option(build_doc "Build user manual" OFF)
option(use_sqlite3 "Add support for sqlite3 output [experimental]." OFF)
option(use_libclang "Add support for libclang parsing." OFF)
+option(qt_static "Link doxywizard with /MT in stead of /MD on windows" OFF)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
include(version)
@@ -31,11 +33,12 @@ if (use_sqlite3)
endif()
if (use_libclang)
set(clang "1" CACHE INTERNAL "used in settings.h")
+ find_package(LibClang REQUIRED)
endif()
if (${CMAKE_SYSTEM} MATCHES "Darwin")
- set(CMAKE_CXX_FLAGS "-Wno-deprecated-register ${CMAKE_CXX_FLAGS}")
+ set(CMAKE_CXX_FLAGS "-Wno-deprecated-register -mmacosx-version-min=10.5 ${CMAKE_CXX_FLAGS}")
find_library(CORESERVICES_LIB CoreServices)
set(EXTRA_LIBS ${CORESERVICES_LIB})
endif()
@@ -59,11 +62,24 @@ endif()
find_package(Iconv REQUIRED)
include_directories(${ICONV_INCLUDE_DIR})
-set(DOXYDOCS ${CMAKE_SOURCE_DIR}/doc CACHE INTERNAL "Path to doxygen docs")
+#set(DOXYDOCS ${CMAKE_SOURCE_DIR}/doc CACHE INTERNAL "Path to doxygen docs")
+set(DOC_INSTALL_DIR "share/doc/packages/doxygen" CACHE STRING "Relative path where to install the documentation")
+set(EXAMPLE_DIR ${CMAKE_SOURCE_DIR}/examples)
+set(DOXYDOCS ${PROJECT_BINARY_DIR}/doc)
set(ENV{DOXYGEN_DOCDIR} ${DOXYDOCS})
set(GENERATED_SRC "${CMAKE_BINARY_DIR}/generated_src" CACHE INTERNAL "Stores generated files")
set(LIBRARY_OUTPUT_PATH ${PROJECT_BINARY_DIR}/lib)
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_BINARY_DIR}/bin)
+set(CUSTOM_INCLUDE_DIR "" CACHE FILEPATH "Extra include path")
+set(CUSTOM_LINK_DIR "" CACHE FILEPATH "Extra library path")
+
+if (${CUSTOM_INCLUDE_DIR})
+ include_directories(${CUSTOM_INCLUDE_DIR})
+endif()
+
+if (${CUSTOM_LINK_DIR})
+ link_directories(${CUSTOM_LINK_DIR})
+endif()
add_subdirectory(libmd5)
add_subdirectory(qtools)