summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2016-03-05 18:53:51 (GMT)
committeralbert-github <albert.tests@gmail.com>2016-03-05 18:53:51 (GMT)
commitc873fad0b4c2948551e53c082a3829243c4ccb9f (patch)
tree6d3dfaac637a3a7e510af39b206243cd76116e3f /CMakeLists.txt
parent7584c292b8d65e016e8e19d7c1698ab6d0c1fdec (diff)
downloadDoxygen-c873fad0b4c2948551e53c082a3829243c4ccb9f.zip
Doxygen-c873fad0b4c2948551e53c082a3829243c4ccb9f.tar.gz
Doxygen-c873fad0b4c2948551e53c082a3829243c4ccb9f.tar.bz2
Adding compilation options for flex/lex and bison/yacc
The pull request #419 didn't work for the ninja build platform The pull request #442 did only work when cmake was called but not during compilation ("make") In this patch we set the LEX_FLAGS and YACC_FLAGS when specified on the command line with cmake to the specified value, in the other case these flags are for the Ninja build system they are omitted and for all other build systems they are set to $(LEX_FLAGS) and $(YACC_FLAGS) so they can be used during runtime as well.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a020f41..4c55859 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,6 +55,14 @@ if (WIN32)
add_definitions(-DLIBICONV_STATIC -D_CRT_SECURE_NO_WARNINGS)
endif()
+if ("${CMAKE_GENERATOR}" MATCHES "Ninja")
+ set(LEX_FLAGS )
+ set(YACC_FLAGS )
+else ("${CMAKE_GENERATOR}" MATCHES "Ninja")
+ set(LEX_FLAGS $(LEX_FLAGS))
+ set(YACC_FLAGS $(YACC_FLAGS))
+endif ("${CMAKE_GENERATOR}" MATCHES "Ninja")
+
find_program(DOT NAMES dot)
find_package(PythonInterp REQUIRED)
find_package(FLEX REQUIRED)