summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eb@emlix.com>2017-10-20 10:48:25 (GMT)
committerRolf Eike Beer <kde@opensource.sf-tec.de>2017-10-20 19:05:44 (GMT)
commit62e87408cb7094eeac130775e62d5b7a6f4a79c9 (patch)
tree26eeb40c5abaab01ea6abbf87865ec91854ca709 /CMakeLists.txt
parentb54b843accb97105ae4afaf24136e33bfd1ea9d4 (diff)
downloadDoxygen-62e87408cb7094eeac130775e62d5b7a6f4a79c9.zip
Doxygen-62e87408cb7094eeac130775e62d5b7a6f4a79c9.tar.gz
Doxygen-62e87408cb7094eeac130775e62d5b7a6f4a79c9.tar.bz2
CMake: avoid if() around the whole contents of documentation CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4be77e0..ba105b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -143,8 +143,11 @@ add_subdirectory(libmd5)
add_subdirectory(qtools)
add_subdirectory(vhdlparser)
add_subdirectory(src)
-add_subdirectory(examples)
-add_subdirectory(doc)
+
+if (build_doc)
+ add_subdirectory(examples)
+ add_subdirectory(doc)
+endif ()
add_subdirectory(addon)