summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <dimitri@stack.nl>2017-07-08 20:29:20 (GMT)
committerDimitri van Heesch <dimitri@stack.nl>2017-07-08 20:29:20 (GMT)
commit82221a3a3f20f7e7cef94b52ac6c575f940b51f3 (patch)
treea7274a138e99a1da651515e68d517e76d04503ad /CMakeLists.txt
parentdaa2c0960aa5044990c3e06afe8c15694e8be48d (diff)
parentbca94d6ca30bde5f01dd17a83cfa63268c0ca664 (diff)
downloadDoxygen-82221a3a3f20f7e7cef94b52ac6c575f940b51f3.zip
Doxygen-82221a3a3f20f7e7cef94b52ac6c575f940b51f3.tar.gz
Doxygen-82221a3a3f20f7e7cef94b52ac6c575f940b51f3.tar.bz2
Merge branch 'master' of https://github.com/dvj/doxygen into dvj-master
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4d75659..d8337d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,14 +35,19 @@ set(clang "0" CACHE INTERNAL "used in settings.h")
if (use_sqlite3)
set(sqlite3 "1" CACHE INTERNAL "used in settings.h")
endif()
+
+set(MACOS_VERSION_MIN 10.5)
if (use_libclang)
set(clang "1" CACHE INTERNAL "used in settings.h")
find_package(LibClang REQUIRED)
+ if (${CMAKE_SYSTEM} MATCHES "Darwin")
+ set(MACOS_VERSION_MIN 10.11)
+ endif()
endif()
if (${CMAKE_SYSTEM} MATCHES "Darwin")
- set(CMAKE_CXX_FLAGS "-Wno-deprecated-register -mmacosx-version-min=10.5 ${CMAKE_CXX_FLAGS}")
- set(CMAKE_C_FLAGS "-Wno-deprecated-register -mmacosx-version-min=10.5 ${CMAKE_C_FLAGS}")
+ set(CMAKE_CXX_FLAGS "-Wno-deprecated-register -mmacosx-version-min=${MACOS_VERSION_MIN} ${CMAKE_CXX_FLAGS}")
+ set(CMAKE_C_FLAGS "-Wno-deprecated-register -mmacosx-version-min=${MACOS_VERSION_MIN} ${CMAKE_C_FLAGS}")
find_library(CORESERVICES_LIB CoreServices)
set(EXTRA_LIBS ${CORESERVICES_LIB})
endif()