summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTravis A. Everett <travis.a.everett@gmail.com>2018-10-17 00:40:13 (GMT)
committerTravis A. Everett <travis.a.everett@gmail.com>2018-10-17 00:40:13 (GMT)
commite4f408eb4aad7fb035847616debe68fe115e2ae4 (patch)
treed666623f6a039f0e1f31b6f3675a916570e38135 /CMakeLists.txt
parenteec2d3b6a9f80715fb590b0fb67b7fe87ba5fee7 (diff)
downloadDoxygen-e4f408eb4aad7fb035847616debe68fe115e2ae4.zip
Doxygen-e4f408eb4aad7fb035847616debe68fe115e2ae4.tar.gz
Doxygen-e4f408eb4aad7fb035847616debe68fe115e2ae4.tar.bz2
sqlite3: require sqlite >= 3.9.0
The generated schema is malformed in versions below 3.9.0.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e0fb55..45c2f2c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,7 +86,10 @@ find_package(BISON REQUIRED)
find_package(Threads)
if (sqlite3)
- find_package(SQLite3 REQUIRED)
+ find_package(SQLite3 REQUIRED)
+ if (SQLITE3_VERSION VERSION_LESS 3.9.0)
+ message(SEND_ERROR "Doxygen requires at least sqlite3 version 3.9.0 (installed: ${SQLITE3_VERSION})")
+ endif()
endif()
find_package(Iconv REQUIRED)