summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Negreanu <adrian.m.negreanu@intel.com>2015-06-16 11:50:21 (GMT)
committerDimitri van Heesch <dimitri@stack.nl>2015-07-18 13:07:23 (GMT)
commit3c4a1ea2ee56f2604c2277f13737d53b3a0b0353 (patch)
treea49fca3f798577cea86fec18c203d61f4499c041 /CMakeLists.txt
parent1989a4918340bcdb5c5447afba1468e7eecc7705 (diff)
downloadDoxygen-3c4a1ea2ee56f2604c2277f13737d53b3a0b0353.zip
Doxygen-3c4a1ea2ee56f2604c2277f13737d53b3a0b0353.tar.gz
Doxygen-3c4a1ea2ee56f2604c2277f13737d53b3a0b0353.tar.bz2
doc: generate Doxygen's documentation.
* use configure_files to avoid different $ semantics when COMMAND lines are expanded in build files. ($$var vs. \$var) * nmake/gmake no longer needed by cmake, when building doc. * explicitly copy doc files into build directory to make it clear what files each build stage uses. Documentation can be built with: mkdir build/ && cd $_ cmake -Dbuild_doc=1 .. # add -G"NMake Makefiles" for nmake make docs # this builds doxygen first v3: replace file(COPY) with proper generated file tagging. v2: Remove option to build documentation independently from doxygen. tested on linux(gmake) and windows(nmake) [thanks albert]
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44f493c..dcb329b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,7 @@ option(english_only "Only compile in support for the English language" OFF)
option(force_qt4 "Forces doxywizard to build using Qt4 even if Qt5 is installed" OFF)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
-set(SOURCE "${CMAKE_SOURCE_DIR}")
+set(TOP "${CMAKE_SOURCE_DIR}")
include(version)
set(sqlite3 "0" CACHE INTERNAL "used in settings.h")
@@ -67,8 +67,6 @@ include_directories(${ICONV_INCLUDE_DIR})
#set(DOXYDOCS ${CMAKE_SOURCE_DIR}/doc CACHE INTERNAL "Path to doxygen docs")
-set(DOC_INSTALL_DIR "share/doc/packages/doxygen" CACHE STRING "Relative path where to install the documentation")
-set(EXAMPLE_DIR ${CMAKE_SOURCE_DIR}/examples)
set(DOXYDOCS ${PROJECT_BINARY_DIR}/doc)
set(ENV{DOXYGEN_DOCDIR} ${DOXYDOCS})
set(GENERATED_SRC "${CMAKE_BINARY_DIR}/generated_src" CACHE INTERNAL "Stores generated files")