summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <dimitri@stack.nl>2015-06-07 15:11:01 (GMT)
committerDimitri van Heesch <dimitri@stack.nl>2015-06-07 15:11:01 (GMT)
commit5446770855a8286092abdd91d9069cb3191c209d (patch)
tree29f7d9da51a535d70a3cca9cdbcf2c282472ddbd /CMakeLists.txt
parenta92e614ac697d5d1fe7f49bae00c7530afda62cb (diff)
downloadDoxygen-5446770855a8286092abdd91d9069cb3191c209d.zip
Doxygen-5446770855a8286092abdd91d9069cb3191c209d.tar.gz
Doxygen-5446770855a8286092abdd91d9069cb3191c209d.tar.bz2
Build fixes for windows build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eba0fd7..6223aa9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,7 @@ endif()
if (WIN32)
set(ICONV_DIR "${CMAKE_SOURCE_DIR}/winbuild")
set(CMAKE_REQUIRED_DEFINITIONS "-DLIBICONV_STATIC")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /bigobj") # needed for language.cpp on 64bit
add_definitions(-DLIBICONV_STATIC -D_CRT_SECURE_NO_WARNINGS)
endif()