summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <doxygen@gmail.com>2020-05-22 14:08:39 (GMT)
committerDimitri van Heesch <doxygen@gmail.com>2020-05-24 07:38:12 (GMT)
commit57730818727420a23e63917e3d035df3926b958f (patch)
treed2e7d58a10416bff524059ac4027580089fc7dc7 /CMakeLists.txt
parente3470060b067bbb5d949de01758aff491fc804c3 (diff)
downloadDoxygen-57730818727420a23e63917e3d035df3926b958f.zip
Doxygen-57730818727420a23e63917e3d035df3926b958f.tar.gz
Doxygen-57730818727420a23e63917e3d035df3926b958f.tar.bz2
Refactoring: Removed creation of MemberDef's for macro definitions from pre.l
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 20c87dc..16c0454 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,7 @@ option(use_libclang "Add support for libclang parsing." OFF)
option(win_static "Link with /MT in stead of /MD on windows" OFF)
option(english_only "Only compile in support for the English language" OFF)
option(force_qt4 "Forces doxywizard to build using Qt4 even if Qt5 is installed" OFF)
+option(enable_coverage "Enable coverage reporting for gcc/clang [development]" OFF)
SET(enlarge_lex_buffers "262144" CACHE INTERNAL "Sets the lex input and read buffers to the specified size")
@@ -159,6 +160,7 @@ if (win_static)
endif()
include(cmake/CompilerWarnings.cmake)
+include(cmake/Coverage.cmake)
add_subdirectory(libmd5)
add_subdirectory(liblodepng)