summaryrefslogtreecommitdiffstats
path: root/addon/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eb@emlix.com>2017-10-20 10:31:29 (GMT)
committerRolf Eike Beer <kde@opensource.sf-tec.de>2017-10-20 18:25:40 (GMT)
commit7c1c75a2c5583415d178e0e46a1a356bef9b0c84 (patch)
tree305f101e105276db4a507171173fe478d67154fb /addon/CMakeLists.txt
parentac5ca4ef86ad50232be75a65fab99302307b7795 (diff)
downloadDoxygen-7c1c75a2c5583415d178e0e46a1a356bef9b0c84.zip
Doxygen-7c1c75a2c5583415d178e0e46a1a356bef9b0c84.tar.gz
Doxygen-7c1c75a2c5583415d178e0e46a1a356bef9b0c84.tar.bz2
CMake: avoid if() around the whole contents of plugin CMakeLists.txt
Just don't call add_subdirectory() if the build flag is not set.
Diffstat (limited to 'addon/CMakeLists.txt')
-rw-r--r--addon/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/addon/CMakeLists.txt b/addon/CMakeLists.txt
new file mode 100644
index 0000000..fd8c73f
--- /dev/null
+++ b/addon/CMakeLists.txt
@@ -0,0 +1,17 @@
+add_subdirectory(doxmlparser)
+
+if (build_app)
+ add_subdirectory(doxyapp)
+endif ()
+
+if (build_parse)
+ add_subdirectory(doxyparse)
+endif ()
+
+if (build_search)
+ add_subdirectory(doxysearch)
+endif ()
+
+if (build_wizard)
+ add_subdirectory(doxywizard)
+endif ()