summaryrefslogtreecommitdiffstats
path: root/addon/doxyparse/CMakeLists.txt
diff options
context:
space:
mode:
authorJoenio Costa <joenio@joenio.me>2017-06-28 02:10:08 (GMT)
committerJoenio Costa <joenio@joenio.me>2017-06-28 02:10:08 (GMT)
commit20af63f43e583a31dfe93f78807aa868f9b9ff14 (patch)
treeeac1804f1be010fb8598647f8e608cd1f9e3d0dd /addon/doxyparse/CMakeLists.txt
parente7e62101a1a659740223c32cdd525b1e66b1cf09 (diff)
downloadDoxygen-20af63f43e583a31dfe93f78807aa868f9b9ff14.zip
Doxygen-20af63f43e583a31dfe93f78807aa868f9b9ff14.tar.gz
Doxygen-20af63f43e583a31dfe93f78807aa868f9b9ff14.tar.bz2
add the number of conditionals path and bugfix
* Rebased with upstream master * Added build instructions to README * Bug 398942 - fixes the problem with instance variables and arguments with the same name Signed-off-by: Antonio Terceiro <terceiro@softwarelivre.org> Signed-off-by: João M. Miranda <joaomm88@gmail.com> Signed-off-by: Paulo Meirelles <paulo@softwarelivre.org> Signed-off-by: Vinicius Daros <vkdaros@mercurio.eclipse.ime.usp.br> Signed-off-by: Jonathan Moraes <arkyebr@gmail.com>
Diffstat (limited to 'addon/doxyparse/CMakeLists.txt')
-rw-r--r--addon/doxyparse/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/addon/doxyparse/CMakeLists.txt b/addon/doxyparse/CMakeLists.txt
index 24f98cb..e4f9021 100644
--- a/addon/doxyparse/CMakeLists.txt
+++ b/addon/doxyparse/CMakeLists.txt
@@ -1,11 +1,21 @@
if (build_parse)
+# configvalues.h
+add_custom_command(
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/src/configgen.py -maph ${CMAKE_SOURCE_DIR}/src/config.xml > ${GENERATED_SRC}/configvalues.h
+ DEPENDS ${CMAKE_SOURCE_DIR}/src/config.xml ${CMAKE_SOURCE_DIR}/src/configgen.py
+ OUTPUT ${GENERATED_SRC}/configvalues.h
+)
+set_source_files_properties(${GENERATED_SRC}/configvalues.h PROPERTIES GENERATED 1)
+
find_package(Iconv)
include_directories(
${CMAKE_SOURCE_DIR}/src
+ ${GENERATED_SRC}
${CMAKE_SOURCE_DIR}/qtools
${ICONV_INCLUDE_DIR}
+ ${CLANG_INCLUDEDIR}
)
add_executable(doxyparse
@@ -21,6 +31,7 @@ ${ICONV_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}
${SQLITE3_LIBRARIES}
${EXTRA_LIBS}
+${CLANG_LIBS}
)
install(TARGETS doxyparse DESTINATION bin)