summaryrefslogtreecommitdiffstats
path: root/addon/doxyparse/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <dimitri@stack.nl>2017-02-19 10:50:12 (GMT)
committerGitHub <noreply@github.com>2017-02-19 10:50:12 (GMT)
commit736cb284b90bf66e514cbb2b73035fd9217488c0 (patch)
tree312b1946856317bea14c3a8966a1c565c12ac3a1 /addon/doxyparse/CMakeLists.txt
parent9e3031e5f448a91fd68f1e9753e6f7beceffc0a1 (diff)
parent82dbb5fe863e13175eda130dcc728b102101ccda (diff)
downloadDoxygen-736cb284b90bf66e514cbb2b73035fd9217488c0.zip
Doxygen-736cb284b90bf66e514cbb2b73035fd9217488c0.tar.gz
Doxygen-736cb284b90bf66e514cbb2b73035fd9217488c0.tar.bz2
Merge pull request #425 from analizo/doxyparse
new addon doxyparse, a source parsing engine
Diffstat (limited to 'addon/doxyparse/CMakeLists.txt')
-rw-r--r--addon/doxyparse/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/addon/doxyparse/CMakeLists.txt b/addon/doxyparse/CMakeLists.txt
new file mode 100644
index 0000000..24f98cb
--- /dev/null
+++ b/addon/doxyparse/CMakeLists.txt
@@ -0,0 +1,28 @@
+if (build_parse)
+
+find_package(Iconv)
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}/src
+ ${CMAKE_SOURCE_DIR}/qtools
+ ${ICONV_INCLUDE_DIR}
+)
+
+add_executable(doxyparse
+doxyparse.cpp
+)
+target_link_libraries(doxyparse
+_doxygen
+qtools
+md5
+doxycfg
+vhdlparser
+${ICONV_LIBRARIES}
+${CMAKE_THREAD_LIBS_INIT}
+${SQLITE3_LIBRARIES}
+${EXTRA_LIBS}
+)
+
+install(TARGETS doxyparse DESTINATION bin)
+
+endif()