summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <dimitri@stack.nl>2015-06-20 21:51:05 (GMT)
committerDimitri van Heesch <dimitri@stack.nl>2015-06-20 21:51:05 (GMT)
commitf63d9ed958d2c06717434e1a90e6417cf2d60f6b (patch)
tree0bd2fb98598d2c87971eb041429b58bf9afee831 /examples/CMakeLists.txt
parentdfe93f9fde39167eae2aeeab929641a9c56cc916 (diff)
downloadDoxygen-f63d9ed958d2c06717434e1a90e6417cf2d60f6b.zip
Doxygen-f63d9ed958d2c06717434e1a90e6417cf2d60f6b.tar.gz
Doxygen-f63d9ed958d2c06717434e1a90e6417cf2d60f6b.tar.bz2
Various minor changes
- made copying doc and example files a target - fixed bug using temparary in the wizard. - Added faq question about extension mapping
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 34abe62..d689eda 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,14 +1,23 @@
if (build_doc)
+file(MAKE_DIRECTORY ${PROJECT_BINARY_DIR}/examples)
file(MAKE_DIRECTORY ${PROJECT_BINARY_DIR}/html/examples)
-file(COPY ${EXAMPLE_DIR} DESTINATION ${PROJECT_BINARY_DIR})
+file(GLOB EXAMPLE_FILES "*")
if (DOT)
set(DIAGRAM_EXAMPLE ${PROJECT_BINARY_DIR}/html/examples/diagrams/html/index.html)
endif()
+# copy all example files
+add_custom_target(copy_examples)
+foreach(example_file ${EXAMPLE_FILES})
+ add_custom_command(TARGET copy_examples PRE_BUILD
+ COMMAND ${CMAKE_COMMAND} -E
+ copy ${example_file} ${PROJECT_BINARY_DIR}/examples)
+endforeach()
+
add_custom_target(examples
- DEPENDS doxygen
+ DEPENDS doxygen copy_examples
${PROJECT_BINARY_DIR}/html/examples/class/html/index.html
${PROJECT_BINARY_DIR}/html/examples/define/html/index.html
${PROJECT_BINARY_DIR}/html/examples/enum/html/index.html