summaryrefslogtreecommitdiffstats
path: root/libversion/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <doxygen@gmail.com>2020-05-15 09:28:16 (GMT)
committerDimitri van Heesch <doxygen@gmail.com>2020-05-15 09:34:17 (GMT)
commit10787eed95266bb1a13c892fe4cf5a695dac1559 (patch)
tree3267c7bc4580d4de7ec5797b5658038ad53e3941 /libversion/CMakeLists.txt
parent12843822b09f0aa3f426387986354d9e1303e41e (diff)
downloadDoxygen-10787eed95266bb1a13c892fe4cf5a695dac1559.zip
Doxygen-10787eed95266bb1a13c892fe4cf5a695dac1559.tar.gz
Doxygen-10787eed95266bb1a13c892fe4cf5a695dac1559.tar.bz2
Refactoring
- Makes doxycfg library more self contained - renames _doxygen library to doxymain - Modernizes Debug implementation - Moves Doxygen::runningTime into Debug - Moves full version string to libversion - Removed mentioning of file version in messages (when FILE_VERSION_FILTER is used) - Move substitute functions into QCString
Diffstat (limited to 'libversion/CMakeLists.txt')
-rw-r--r--libversion/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/libversion/CMakeLists.txt b/libversion/CMakeLists.txt
index 6952cea..009c236 100644
--- a/libversion/CMakeLists.txt
+++ b/libversion/CMakeLists.txt
@@ -19,6 +19,7 @@ include_directories(
add_library(doxygen_version STATIC
${POST_CONFIGURE_DOXYGEN_VERSION_FILE}
${POST_CONFIGURE_GIT_VERSION_FILE}
+ fullversion.cpp
)
add_dependencies( doxygen_version check_git_repository )