summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2017-06-21 12:32:25 (GMT)
committerBartosz Golaszewski <brgl@bgdev.pl>2017-06-21 13:32:03 (GMT)
commitcc3a9e611c15f32ae4913a87306699db60758245 (patch)
treeea508b6342471f4e7c2df9e284ef4902961bbe51 /src/CMakeLists.txt
parente7e62101a1a659740223c32cdd525b1e66b1cf09 (diff)
downloadDoxygen-cc3a9e611c15f32ae4913a87306699db60758245.zip
Doxygen-cc3a9e611c15f32ae4913a87306699db60758245.tar.gz
Doxygen-cc3a9e611c15f32ae4913a87306699db60758245.tar.bz2
build: fix the way lang_cfg.h is generated
This header is generated by running cmake/lang_cfg.cmake and redirecting its stderr. If any warning is emitted by this script, it ends up in the generated header and breaks the build. To avoid such problems: pass the path to the header as an argument to the cmake script and use the cmake 'file' command instead of 'message'. We can't even use message(STATUS...) as - although it prints to stdout as opposed to other types of messages - it prepends all output with a double hyphen.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 08c8439..dcf4ef8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -73,7 +73,7 @@ set_source_files_properties(${GENERATED_SRC}/ce_parse.h PROPERTIES GENERATED 1)
# lang_cfg.h
add_custom_command(
COMMENT "Generating ${GENERATED_SRC}/lang_cfg.h"
- COMMAND ${CMAKE_COMMAND} -P ${CMAKE_SOURCE_DIR}/cmake/lang_cfg.cmake ${LANG_CODES} 2> ${GENERATED_SRC}/lang_cfg.h
+ COMMAND ${CMAKE_COMMAND} -P ${CMAKE_SOURCE_DIR}/cmake/lang_cfg.cmake ${GENERATED_SRC}/lang_cfg.h ${LANG_CODES}
DEPENDS ${LANGUAGE_FILES}
OUTPUT ${GENERATED_SRC}/lang_cfg.h
)