summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2019-07-20 13:31:30 (GMT)
committeralbert-github <albert.tests@gmail.com>2019-07-20 13:31:30 (GMT)
commitefc67de9d1a4e36ab94164352778fd19f33652b3 (patch)
tree33a72eec96c4b7470d0f40298e795589b640a186 /src/CMakeLists.txt
parent242abf259fcd639ebf33162b6f442c80b0fe0043 (diff)
downloadDoxygen-efc67de9d1a4e36ab94164352778fd19f33652b3.zip
Doxygen-efc67de9d1a4e36ab94164352778fd19f33652b3.tar.gz
Doxygen-efc67de9d1a4e36ab94164352778fd19f33652b3.tar.bz2
Option for 'input buffer overflow'
Cmake option `-Denlarge_lex_buffers=<size>` to enlarge input and read buffers for source code lexers.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index bc79194..b73dab7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -16,7 +16,7 @@ file(MAKE_DIRECTORY ${GENERATED_SRC})
file(GLOB LANGUAGE_FILES "${CMAKE_SOURCE_DIR}/src/translator_??.h")
# instead of increasebuffer.py
-add_definitions(-DYY_BUF_SIZE=262144 -DYY_READ_BUF_SIZE=262144)
+add_definitions(-DYY_BUF_SIZE=${enlarge_lex_buffers} -DYY_READ_BUF_SIZE=${enlarge_lex_buffers})
# generate settings.h
file(GENERATE OUTPUT ${GENERATED_SRC}/settings.h