summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorWataru Ashihara <wataash@wataash.com>2020-05-23 09:22:27 (GMT)
committerWataru Ashihara <wataash@wataash.com>2020-05-23 10:10:37 (GMT)
commit1a683c1864eaac3255f464dd63eff3619bd9ced6 (patch)
treebd03e81397eaeae995f67e33c4dc7144e456adf7 /src/CMakeLists.txt
parentff5ba4a40fa13c0987272d463ba0edc57bc10fa6 (diff)
downloadDoxygen-1a683c1864eaac3255f464dd63eff3619bd9ced6.zip
Doxygen-1a683c1864eaac3255f464dd63eff3619bd9ced6.tar.gz
Doxygen-1a683c1864eaac3255f464dd63eff3619bd9ced6.tar.bz2
Improve flex/bison debuggability with gdb
This changes "#line" in generated C++ source: #line 26 "doctokenizer.l" to: #line 26 "/absolute/path/to/doctokenizer.l" so that gdb can recognize the original .l .y source locations and step into them.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e880722..3230a4b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -129,11 +129,11 @@ foreach(lex_file ${LEX_FILES})
)
set_source_files_properties(${GENERATED_SRC}/${lex_file}.l.h PROPERTIES GENERATED 1)
- FLEX_TARGET(${lex_file} ${lex_file}.l ${GENERATED_SRC}/${lex_file}.cpp COMPILE_FLAGS "${LEX_FLAGS}")
+ FLEX_TARGET(${lex_file} ${CMAKE_CURRENT_LIST_DIR}/${lex_file}.l ${GENERATED_SRC}/${lex_file}.cpp COMPILE_FLAGS "${LEX_FLAGS}")
endforeach()
-BISON_TARGET(constexp constexp.y ${GENERATED_SRC}/ce_parse.cpp COMPILE_FLAGS "${YACC_FLAGS}")
+BISON_TARGET(constexp ${CMAKE_CURRENT_LIST_DIR}/constexp.y ${GENERATED_SRC}/ce_parse.cpp COMPILE_FLAGS "${YACC_FLAGS}")
add_library(doxycfg STATIC
${GENERATED_SRC}/lang_cfg.h