summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <doxygen@gmail.com>2020-10-26 19:41:56 (GMT)
committerDimitri van Heesch <doxygen@gmail.com>2020-10-28 20:32:40 (GMT)
commit0c0889e331305ea5b4f5c7a58c4a0e82da6111cd (patch)
treea24d567e9b80518ccd6fd9b77f0f3449c74ad8a1 /src/CMakeLists.txt
parent5f34e8ae667c24900e61c72e7dfc213d53a7cb05 (diff)
downloadDoxygen-0c0889e331305ea5b4f5c7a58c4a0e82da6111cd.zip
Doxygen-0c0889e331305ea5b4f5c7a58c4a0e82da6111cd.tar.gz
Doxygen-0c0889e331305ea5b4f5c7a58c4a0e82da6111cd.tar.bz2
Refactoring: introduce SymbolResolver to group symbol lookup routines
- Main goal was to avoid use of global state.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c3d6f13..68de622 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -296,6 +296,7 @@ add_library(doxymain STATIC
searchindex.cpp
sqlite3gen.cpp
stlsupport.cpp
+ symbolresolver.cpp
tagreader.cpp
template.cpp
textdocvisitor.cpp