summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTomáš Chvátal <tchvatal@suse.com>2015-09-01 07:46:46 (GMT)
committerTomáš Chvátal <tchvatal@suse.com>2015-09-01 07:46:46 (GMT)
commit37a148f6e35523fd2bbbdbc37e6ed838684c6d90 (patch)
treeb5ac78fd9ebdaba792621ba3ed524d814f800a60 /src/CMakeLists.txt
parent5aa4ade86499ba615da48875a9e7292ddd22c22f (diff)
downloadDoxygen-37a148f6e35523fd2bbbdbc37e6ed838684c6d90.zip
Doxygen-37a148f6e35523fd2bbbdbc37e6ed838684c6d90.tar.gz
Doxygen-37a148f6e35523fd2bbbdbc37e6ed838684c6d90.tar.bz2
Use STATIC libraries to prevent them being shared
This can happen when user override definition of -DBUILD_SHARED_LIBS=ON. Without this hard-enforce the libraries would be generated as shared while never installed. Thus resulting in broken binaries.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 155bf77..eb030d4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -106,7 +106,7 @@ FLEX_TARGET(config config.l ${GENERATED_SRC}/config.cpp
BISON_TARGET(vhdlparser vhdlparser.y ${GENERATED_SRC}/vhdlparser.cpp COMPILE_FLAGS "-l -p vhdlscannerYY")
BISON_TARGET(constexp constexp.y ${GENERATED_SRC}/ce_parse.cpp COMPILE_FLAGS "-l -p constexpYY")
-add_library(doxycfg
+add_library(doxycfg STATIC
${GENERATED_SRC}/lang_cfg.h
${GENERATED_SRC}/config.cpp
${GENERATED_SRC}/configoptions.cpp
@@ -114,7 +114,7 @@ add_library(doxycfg
portable_c.c
)
-add_library(_doxygen
+add_library(_doxygen STATIC
# custom generated files
${GENERATED_SRC}/lang_cfg.h
${GENERATED_SRC}/settings.h