summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <doxygen@gmail.com>2020-04-30 18:35:32 (GMT)
committerDimitri van Heesch <doxygen@gmail.com>2020-04-30 18:35:32 (GMT)
commit5456e9a65c2e7a29f61d17d19906aa9616678ca6 (patch)
tree12cb281171c2a9049d1eeb55b3a0894a73006cff /src/CMakeLists.txt
parentf07af121a870e909c1820cade76c502a44f99d23 (diff)
downloadDoxygen-5456e9a65c2e7a29f61d17d19906aa9616678ca6.zip
Doxygen-5456e9a65c2e7a29f61d17d19906aa9616678ca6.tar.gz
Doxygen-5456e9a65c2e7a29f61d17d19906aa9616678ca6.tar.bz2
Fix for overruling flags that did work with the Visual Studio compiler
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e512ed5..780352a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -285,7 +285,10 @@ add_library(_doxygen STATIC
# LLVM/clang headers give a lot of warnings with -Wshadow and -Wcast-align so we disable them for
# the one file that includes them
+
+if (NOT MSVC)
set_source_files_properties(clangparser.cpp PROPERTIES COMPILE_FLAGS "-Wno-shadow -Wno-cast-align")
+endif()
##foreach(lex_file ${LEX_FILES})
##add_library(_doxygen STATIC ${GENERATED_SRC}/${lex_file}.l.h)