summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2020-12-24 11:16:55 (GMT)
committeralbert-github <albert.tests@gmail.com>2020-12-24 11:16:55 (GMT)
commitcb351b9cfc13ea5f4049182a2b922ea667f06045 (patch)
tree93cbec10fe4c5b0fa062e704b6dc487943b38bbb /src/CMakeLists.txt
parent259d45b94b83523a508b42e71cac1441f2939ac3 (diff)
downloadDoxygen-cb351b9cfc13ea5f4049182a2b922ea667f06045.zip
Doxygen-cb351b9cfc13ea5f4049182a2b922ea667f06045.tar.gz
Doxygen-cb351b9cfc13ea5f4049182a2b922ea667f06045.tar.bz2
Refactoring position of layout_default.xml
The position of the `layout_defaul.xml` was still done by a dedicated script and not by the resource manager.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 912c67e..5004a95 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -100,14 +100,6 @@ add_custom_command(
)
set_source_files_properties(${GENERATED_SRC}/resources.cpp PROPERTIES GENERATED 1)
-# layout_default.xml
-add_custom_command(
- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_LIST_DIR}/to_c_cmd.py < ${CMAKE_CURRENT_LIST_DIR}/layout_default.xml > ${GENERATED_SRC}/layout_default.xml.h
- DEPENDS ${CMAKE_CURRENT_LIST_DIR}/layout_default.xml ${CMAKE_CURRENT_LIST_DIR}/to_c_cmd.py
- OUTPUT ${GENERATED_SRC}/layout_default.xml.h
-)
-set_source_files_properties(${GENERATED_SRC}/layout_default.xml.h PROPERTIES GENERATED 1)
-
set(LEX_FILES scanner
code
pyscanner
@@ -220,7 +212,6 @@ add_library(doxymain STATIC
${GENERATED_SRC}/ce_parse.cpp
# custom generated files
${GENERATED_SRC}/lang_cfg.h
- ${GENERATED_SRC}/layout_default.xml.h
${GENERATED_SRC}/ce_parse.h
${GENERATED_SRC}/resources.cpp
#