summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <doxygen@gmail.com>2020-04-30 17:29:52 (GMT)
committerDimitri van Heesch <doxygen@gmail.com>2020-04-30 17:29:52 (GMT)
commitf07af121a870e909c1820cade76c502a44f99d23 (patch)
tree1861ef5c9e4a5a686dbe22088ff13eea40a599b9 /src/CMakeLists.txt
parent6ca67aa0e617816789f2a662c86ad82426377b71 (diff)
downloadDoxygen-f07af121a870e909c1820cade76c502a44f99d23.zip
Doxygen-f07af121a870e909c1820cade76c502a44f99d23.tar.gz
Doxygen-f07af121a870e909c1820cade76c502a44f99d23.tar.bz2
Refactoring: modernize g_inputFiles and the parameters of readFileOrDirectory
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 146f67f..e512ed5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -283,6 +283,10 @@ add_library(_doxygen STATIC
xmlgen.cpp
)
+# LLVM/clang headers give a lot of warnings with -Wshadow and -Wcast-align so we disable them for
+# the one file that includes them
+set_source_files_properties(clangparser.cpp PROPERTIES COMPILE_FLAGS "-Wno-shadow -Wno-cast-align")
+
##foreach(lex_file ${LEX_FILES})
##add_library(_doxygen STATIC ${GENERATED_SRC}/${lex_file}.l.h)
##endforeach()