summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 20 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2621844..cd0fcaa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,14 +19,15 @@ option(build_app "Example showing how to embed doxygen in an application."
option(build_parse "Parses source code and dumps the dependencies between the code elements." OFF)
option(build_xmlparser "Example showing how to parse doxygen's XML output." OFF)
option(build_search "Build external search tools (doxysearch and doxyindexer)" OFF)
-option(build_doc "Build user manual" OFF)
+option(build_doc "Build user manual (HTML and PDF)" OFF)
+option(build_doc_chm "Build user manual (CHM)" OFF)
option(use_sqlite3 "Add support for sqlite3 output [experimental]." OFF)
option(use_libclang "Add support for libclang parsing." OFF)
option(win_static "Link with /MT in stead of /MD on windows" OFF)
option(english_only "Only compile in support for the English language" OFF)
option(force_qt4 "Forces doxywizard to build using Qt4 even if Qt5 is installed" OFF)
-SET(enlarge_lex_buffers "262144" CACHE INTERNAL "Sets the lex input and read buffere to the specified size")
+SET(enlarge_lex_buffers "262144" CACHE INTERNAL "Sets the lex input and read buffers to the specified size")
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
set(TOP "${CMAKE_SOURCE_DIR}")
@@ -48,8 +49,8 @@ if (use_libclang)
endif()
endif()
-# use C++11 standard for compiling (libclang option requires it)
-set(CMAKE_CXX_STANDARD 11)
+# use C++14 standard for compiling (libclang option requires it)
+set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS ON)
@@ -69,6 +70,9 @@ if (WIN32)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /bigobj") # needed for language.cpp on 64bit
add_definitions(-DLIBICONV_STATIC -D_CRT_SECURE_NO_WARNINGS)
endif()
+ if (CMAKE_GENERATOR MATCHES "NMake Makefiles")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /EHsc")
+ endif()
endif()
if(POLICY CMP0063)
@@ -81,9 +85,11 @@ set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
if (CMAKE_GENERATOR MATCHES "Ninja")
set(LEX_FLAGS )
set(YACC_FLAGS )
+ set(JAVACC_FLAGS )
else ()
set(LEX_FLAGS $(LEX_FLAGS))
set(YACC_FLAGS $(YACC_FLAGS))
+ set(JAVACC_FLAGS $(JAVACC_FLAGS))
endif ()
find_program(DOT NAMES dot)
@@ -160,6 +166,16 @@ add_subdirectory(qtools)
add_subdirectory(vhdlparser)
add_subdirectory(src)
+if (build_doc_chm)
+ if (WIN32)
+ find_package(HTMLHelp REQUIRED)
+ set(build_doc ON)
+ else ()
+ message(WARNING "CHM documentation generation not supported for this platform, ignoring setting.")
+ set(build_doc_chm OFF)
+ endif ()
+endif ()
+
if (build_doc)
add_subdirectory(examples)
add_subdirectory(doc)