summaryrefslogtreecommitdiffstats
path: root/addon/doxyparse/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'addon/doxyparse/CMakeLists.txt')
-rw-r--r--addon/doxyparse/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/addon/doxyparse/CMakeLists.txt b/addon/doxyparse/CMakeLists.txt
new file mode 100644
index 0000000..24f98cb
--- /dev/null
+++ b/addon/doxyparse/CMakeLists.txt
@@ -0,0 +1,28 @@
+if (build_parse)
+
+find_package(Iconv)
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}/src
+ ${CMAKE_SOURCE_DIR}/qtools
+ ${ICONV_INCLUDE_DIR}
+)
+
+add_executable(doxyparse
+doxyparse.cpp
+)
+target_link_libraries(doxyparse
+_doxygen
+qtools
+md5
+doxycfg
+vhdlparser
+${ICONV_LIBRARIES}
+${CMAKE_THREAD_LIBS_INIT}
+${SQLITE3_LIBRARIES}
+${EXTRA_LIBS}
+)
+
+install(TARGETS doxyparse DESTINATION bin)
+
+endif()