summaryrefslogtreecommitdiffstats
path: root/demos/mobile/quickhit/debian/rules
diff options
context:
space:
mode:
authorQt Continuous Integration System <qt-info@nokia.com>2011-04-07 13:54:48 (GMT)
committerQt Continuous Integration System <qt-info@nokia.com>2011-04-07 13:54:48 (GMT)
commit46082389f2a700a1f98826e0c575ab4e31059761 (patch)
treeaa19249a7fb469176fb22adfa9a1b702ae3be6c0 /demos/mobile/quickhit/debian/rules
parent8031eada2f81963865390b4d899631b09d4ca6f3 (diff)
parent7c8980ee041e874a6c430f01b2daff4955517b03 (diff)
downloadQt-46082389f2a700a1f98826e0c575ab4e31059761.zip
Qt-46082389f2a700a1f98826e0c575ab4e31059761.tar.gz
Qt-46082389f2a700a1f98826e0c575ab4e31059761.tar.bz2
Merge branch 'qt-master-from-4.7' of scm.dev.nokia.troll.no:qt/qt-integration into master-integration
* 'qt-master-from-4.7' of scm.dev.nokia.troll.no:qt/qt-integration: (94 commits) Not possible to enter negative values to widgets with numeric fields QmlViewer: Enable remote qml debugging QDeclarativeDebug: Warn user for Qt configured with -no-declarative-debug Improve Flickable dynamics and allow platform specific tweaking. Fixed the declarative headers and includes within qdoc. Removed invalid public slots section. Minor feature fix led to refactoring for i18n's sake. Fixed string-int concatenation issue. Fixed license headers for examples in 4.7 qdoc: Allowed multiple values for certain metadata tags. Removing extra comma in `enum' declaration. Take phonon backend back in qt.iby Mac: p2 combobox regression fix win32-g++: Correct the order of linked Windows libraries Remove SIGBUS emission from QNetworkSession destruction. Remove obsolete files from qt.iby Fix QGradient stop with NaN position on Symbian. win32-g++: Correct the order of linked Windows libraries Fixing a traling space on if statement that fails in Solaris. Do not add project path to SYMBIAN_MATCHED_TRANSLATIONS if not needed ...
Diffstat (limited to 'demos/mobile/quickhit/debian/rules')
-rw-r--r--demos/mobile/quickhit/debian/rules91
1 files changed, 91 insertions, 0 deletions
diff --git a/demos/mobile/quickhit/debian/rules b/demos/mobile/quickhit/debian/rules
new file mode 100644
index 0000000..b485428
--- /dev/null
+++ b/demos/mobile/quickhit/debian/rules
@@ -0,0 +1,91 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+APPNAME := quickhit
+
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+ #docbook-to-man debian/$(APPNAME).sgml > $(APPNAME).1
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ $(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/$(APPNAME).
+ $(MAKE) INSTALL_ROOT="$(CURDIR)"/debian/$(APPNAME) install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ # dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure