summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/phonon/ds9/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin McPherson <justin.mcpherson@nokia.com>2009-11-11 04:02:06 (GMT)
committerJustin McPherson <justin.mcpherson@nokia.com>2009-11-12 05:39:38 (GMT)
commit70490a3f5078f215c905b84fbb11a108dc973a07 (patch)
treedd4de96d501a63cde5f7a5be5b796bfdd5464a5d /src/3rdparty/phonon/ds9/CMakeLists.txt
parent80c24f730c3443e8c05fca374fca365456034fe8 (diff)
downloadQt-70490a3f5078f215c905b84fbb11a108dc973a07.zip
Qt-70490a3f5078f215c905b84fbb11a108dc973a07.tar.gz
Qt-70490a3f5078f215c905b84fbb11a108dc973a07.tar.bz2
Phonon; Integrate changes to cmake files.
Reviewed-by: TrustMe
Diffstat (limited to 'src/3rdparty/phonon/ds9/CMakeLists.txt')
-rw-r--r--src/3rdparty/phonon/ds9/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/3rdparty/phonon/ds9/CMakeLists.txt b/src/3rdparty/phonon/ds9/CMakeLists.txt
index 1bb6f6f..7378b53 100644
--- a/src/3rdparty/phonon/ds9/CMakeLists.txt
+++ b/src/3rdparty/phonon/ds9/CMakeLists.txt
@@ -40,14 +40,15 @@ if (BUILD_PHONON_DS9)
)
add_definitions(-DPHONON_MAKE_QT_ONLY_BACKEND -DUNICODE)
- automoc4_add_library(phonon_ds9 SHARED ${phonon_ds9_SRCS})
+ automoc4_add_library(phonon_ds9 MODULE ${phonon_ds9_SRCS})
set_target_properties(phonon_ds9 PROPERTIES PREFIX "")
target_link_libraries(phonon_ds9
${PHONON_LIBS} ${QT_QTOPENGL_LIBRARY} ${OPENGL_gl_LIBRARY}
dxguid strmiids dmoguids msdmo ole32 oleaut32 uuid gdi32)
+ # 'MODULE' is treated as a LIBRARY
install(TARGETS phonon_ds9
RUNTIME DESTINATION ${BIN_INSTALL_DIR}/phonon_backend
- LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+ LIBRARY DESTINATION ${BIN_INSTALL_DIR}/phonon_backend
ARCHIVE DESTINATION ${LIB_INSTALL_DIR})
install(FILES ds9.desktop DESTINATION ${SERVICES_INSTALL_DIR}/phononbackends)
endif (BUILD_PHONON_DS9)