summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/libpng/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/libpng/CMakeLists.txt')
-rw-r--r--src/3rdparty/libpng/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/3rdparty/libpng/CMakeLists.txt b/src/3rdparty/libpng/CMakeLists.txt
index 2ee5bf3..cc15850 100644
--- a/src/3rdparty/libpng/CMakeLists.txt
+++ b/src/3rdparty/libpng/CMakeLists.txt
@@ -33,7 +33,7 @@ enable_testing()
set(PNGLIB_MAJOR 1)
set(PNGLIB_MINOR 5)
-set(PNGLIB_RELEASE 1)
+set(PNGLIB_RELEASE 4)
set(PNGLIB_NAME libpng${PNGLIB_MAJOR}${PNGLIB_MINOR})
set(PNGLIB_VERSION ${PNGLIB_MAJOR}.${PNGLIB_MINOR}.${PNGLIB_RELEASE})
@@ -147,10 +147,6 @@ set(pngtest_sources
add_definitions(-DPNG_CONFIGURE_LIBPNG)
-if(_AIX)
- add_definitions(-D_ALL_SOURCE)
-endif(_AIX)
-
if(MSVC)
add_definitions(-DPNG_NO_MODULEDEF -D_CRT_SECURE_NO_DEPRECATE)
endif(MSVC)
@@ -264,7 +260,7 @@ install(CODE ${PNG_CONFIG_INSTALL_CODE})
# SET UP LINKS
if(PNG_SHARED)
set_target_properties(${PNG_LIB_NAME} PROPERTIES
-# VERSION 15.${PNGLIB_RELEASE}.1.5.1
+# VERSION 15.${PNGLIB_RELEASE}.1.5.4
VERSION 15.${PNGLIB_RELEASE}.0
SOVERSION 15
CLEAN_DIRECT_OUTPUT 1)