summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/phonon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/phonon/CMakeLists.txt')
-rw-r--r--src/3rdparty/phonon/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/3rdparty/phonon/CMakeLists.txt b/src/3rdparty/phonon/CMakeLists.txt
index e2054d3..fd6368c 100644
--- a/src/3rdparty/phonon/CMakeLists.txt
+++ b/src/3rdparty/phonon/CMakeLists.txt
@@ -94,7 +94,7 @@ if (CMAKE_COMPILER_IS_GNUCXX)
set( __KDE_HAVE_GCC_VISIBILITY ${__KDE_HAVE_GCC_VISIBILITY} CACHE BOOL "GCC support for hidden visibility")
# get the gcc version
- exec_program(${CMAKE_C_COMPILER} ARGS --version OUTPUT_VARIABLE _gcc_version_info)
+ exec_program(${CMAKE_C_COMPILER} ARGS ${CMAKE_C_COMPILER_ARG1} --version OUTPUT_VARIABLE _gcc_version_info)
string (REGEX MATCH "[345]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
# gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the patch level, handle this here: