summaryrefslogtreecommitdiffstats
path: root/SConstruct
diff options
context:
space:
mode:
authorSteven Knight <knight@baldmt.com>2002-11-12 04:24:15 (GMT)
committerSteven Knight <knight@baldmt.com>2002-11-12 04:24:15 (GMT)
commit6a9cd3a308b6aa70d0fbaa7bb32e5a3c8fd32052 (patch)
tree4a34ebd34c3d15b05b322e099e4825c901e503b0 /SConstruct
parent8dbe61168174137944a5bc55ea5a9ff389336376 (diff)
downloadSCons-6a9cd3a308b6aa70d0fbaa7bb32e5a3c8fd32052.zip
SCons-6a9cd3a308b6aa70d0fbaa7bb32e5a3c8fd32052.tar.gz
SCons-6a9cd3a308b6aa70d0fbaa7bb32e5a3c8fd32052.tar.bz2
Arrange for local copies of files in build/ so the Aegis build will continue to work.
Diffstat (limited to 'SConstruct')
-rw-r--r--SConstruct8
1 files changed, 7 insertions, 1 deletions
diff --git a/SConstruct b/SConstruct
index 15e0db4..143f1a6 100644
--- a/SConstruct
+++ b/SConstruct
@@ -461,9 +461,11 @@ for p in [ scons ]:
# like this because we put a preamble in it that will chdir()
# to the directory in which setup.py exists.
#
+ setup_py = os.path.join(build, 'setup.py')
env.Update(PKG = pkg,
PKG_VERSION = pkg_version,
- SETUP_PY = os.path.join(build, 'setup.py'))
+ SETUP_PY = setup_py)
+ Local(setup_py)
#
# Read up the list of source files from our MANIFEST.in.
@@ -540,6 +542,7 @@ for p in [ scons ]:
# Now go through and arrange to create whatever packages we can.
#
build_src_files = map(lambda x, b=build: os.path.join(b, x), src_files)
+ apply(Local, build_src_files, {})
distutils_formats = []
@@ -678,6 +681,7 @@ for p in [ scons ]:
for d in p['debian_deps']:
b = env.SCons_revision(os.path.join(build, d), d)
env.Depends(deb, b)
+ Local(b)
env.Command(deb, build_src_files, [
"cd %s && fakeroot make -f debian/rules PYTHON=$PYTHON BUILDDEB_OPTIONS=--destdir=../../build/dist binary" % build,
])
@@ -788,6 +792,8 @@ if change:
env.Command(b_psv_stamp, src_deps + b_ps_files, cmds)
+ apply(Local, b_ps_files, {})
+
if gzip:
env.Command(src_tar_gz, b_psv_stamp,