summaryrefslogtreecommitdiffstats
path: root/SConstruct
diff options
context:
space:
mode:
authorSteven Knight <knight@baldmt.com>2004-08-18 16:22:42 (GMT)
committerSteven Knight <knight@baldmt.com>2004-08-18 16:22:42 (GMT)
commit13c6522a162eeba44371fed2fbb8f918e9ba3457 (patch)
tree90974d78c9a4a97699c2ec879d28e0f4b713c6a5 /SConstruct
parentd2ae30081e82d18f88a752b3c7b8a26f944314e8 (diff)
downloadSCons-13c6522a162eeba44371fed2fbb8f918e9ba3457.zip
SCons-13c6522a162eeba44371fed2fbb8f918e9ba3457.tar.gz
SCons-13c6522a162eeba44371fed2fbb8f918e9ba3457.tar.bz2
Initialize the new branch for release.
Diffstat (limited to 'SConstruct')
-rw-r--r--SConstruct17
1 files changed, 9 insertions, 8 deletions
diff --git a/SConstruct b/SConstruct
index a3e0903..09ec77c 100644
--- a/SConstruct
+++ b/SConstruct
@@ -39,7 +39,7 @@ import sys
import time
project = 'scons'
-default_version = '0.95'
+default_version = '0.96'
copyright = "Copyright (c) %s The SCons Foundation" % copyright_years
Default('.')
@@ -104,13 +104,14 @@ elif aesub:
else:
revision = default_version
-a = string.split(revision, '.')
-arr = [a[0]]
-for s in a[1:]:
- if len(s) == 1:
- s = '0' + s
- arr.append(s)
-revision = string.join(arr, '.')
+# This is old code that adds an initial "0" to revision numbers < 10.
+#a = string.split(revision, '.')
+#arr = [a[0]]
+#for s in a[1:]:
+# if len(s) == 1:
+# s = '0' + s
+# arr.append(s)
+#revision = string.join(arr, '.')
# Here's how we'd turn the calculated $revision into our package $version.
# This makes it difficult to coordinate with other files (debian/changelog