diff options
author | William Deegan <bill@baddogconsulting.com> | 2021-08-01 21:24:41 (GMT) |
---|---|---|
committer | William Deegan <bill@baddogconsulting.com> | 2021-08-01 21:24:41 (GMT) |
commit | 01dea5f5bcd6178ba53aba668ab94f6bef5cb969 (patch) | |
tree | 96c07fbdfc53bc6aeee1a9304254c3fe25cc6773 /SConstruct | |
parent | 6535544584f4faaf25e2f1bb3cee0fca4abf83c1 (diff) | |
download | SCons-01dea5f5bcd6178ba53aba668ab94f6bef5cb969.zip SCons-01dea5f5bcd6178ba53aba668ab94f6bef5cb969.tar.gz SCons-01dea5f5bcd6178ba53aba668ab94f6bef5cb969.tar.bz2 |
update packing and build logic to enable distro package maintainers to build their packages from root of repo
Diffstat (limited to 'SConstruct')
-rw-r--r-- | SConstruct | 8 |
1 files changed, 6 insertions, 2 deletions
@@ -196,7 +196,7 @@ Export('command_line', 'env', 'whereis', 'revaction') SConscript('doc/SConscript') -# Copy manpage's into base dir for inclusign in pypi packages +# Copy manpage's into base dir for inclusion in pypi packages man_pages = env.Install("#/", Glob("#/build/doc/man/*.1")) # Build packages for pypi @@ -210,7 +210,11 @@ tgz_file = env.Command('$DISTDIR/SCons-${VERSION}.tar.gz', ['setup.cfg', 'setup. # Now set depends so the above run in a particular order env.Depends(tgz_file, [zip_file, wheel]) -env.AddPostAction(tgz_file, Delete(man_pages)) + +# NOTE: Commenting this out as the manpages are expected to be in the base directory when manually +# running setup.py from the base of the repo. +# NOTE: This used by distro package maintainers. +# env.AddPostAction(tgz_file, Delete(man_pages)) # TODO add auto copyright date to README.rst, LICENSE # TODO build API DOCS |