diff options
author | Gary Oberbrunner <garyo@oberbrunner.com> | 2012-08-13 03:25:31 (GMT) |
---|---|---|
committer | Gary Oberbrunner <garyo@oberbrunner.com> | 2012-08-13 03:25:31 (GMT) |
commit | fa19ee19b1048e25a8915c6e9c0c7bef11d28481 (patch) | |
tree | d623ba107f87296c3b7101d5d798e767125ba2f4 /SConstruct | |
parent | 8a4cdff25c3e2f765c288bc7ef749343ccb7ff4a (diff) | |
download | SCons-fa19ee19b1048e25a8915c6e9c0c7bef11d28481.zip SCons-fa19ee19b1048e25a8915c6e9c0c7bef11d28481.tar.gz SCons-fa19ee19b1048e25a8915c6e9c0c7bef11d28481.tar.bz2 |
Fix Debian build process.
Each release needs to update debian/changelog, and it needs
to be in a particular format since the deb build process
reads and parses it to get the version number in the .deb.
Also fixed a few other deb-build-related errors.
Diffstat (limited to 'SConstruct')
-rw-r--r-- | SConstruct | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -1026,7 +1026,7 @@ for p in [ scons ]: if dh_builddeb and fakeroot: # Our Debian packaging builds directly into build/dist, # so we don't need to Install() the .debs. - deb = os.path.join(build_dir, 'dist', "%s_%s-1_all.deb" % (pkg, version)) + deb = os.path.join(build_dir, 'dist', "%s_%s_all.deb" % (pkg, version)) for d in p['debian_deps']: b = env.SCons_revision(os.path.join(build, d), d) env.Depends(deb, b) |