summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorSteven Knight <knight@baldmt.com>2001-11-16 22:06:52 (GMT)
committerSteven Knight <knight@baldmt.com>2001-11-16 22:06:52 (GMT)
commit76166c77f852377b6139a9414cc355fe2661a0e7 (patch)
treefe77db2a491d0f8f0aa6c743c1e1f5b21a1914ed /debian
parent9508d219188fcd2ad8eb2d24606d1b9c611e9ed2 (diff)
downloadSCons-76166c77f852377b6139a9414cc355fe2661a0e7.zip
SCons-76166c77f852377b6139a9414cc355fe2661a0e7.tar.gz
SCons-76166c77f852377b6139a9414cc355fe2661a0e7.tar.bz2
Add the scons package.
Diffstat (limited to 'debian')
-rw-r--r--debian/control12
-rw-r--r--debian/rules38
-rw-r--r--debian/scons.postinst27
-rw-r--r--debian/scons.prerm14
4 files changed, 77 insertions, 14 deletions
diff --git a/debian/control b/debian/control
index 5a5ae24..e628688 100644
--- a/debian/control
+++ b/debian/control
@@ -7,8 +7,7 @@ Build-Depends: debhelper
Package: scons
Architecture: all
-Depends: python-scons|python2-scons,python-base(>=1.5.2)|python2-base
-Suggests: python-scons, python2-scons
+Depends: python-base(>=1.5.2)|python2-base
Description: An Open Source software construction tool
SCons is an Open Source software construction tool--that is, a build tool; an
improved substitute for the classic Make utility; a better way to build
@@ -29,3 +28,12 @@ Description: SCons Python 2.0 extension modules
SCons is an Open Source software construction tool--that is, a build tool; an
improved substitute for the classic Make utility; a better way to build
software.
+
+Package: scons-script
+Architecture: all
+Depends: python-scons|python2-scons,python-base(>=1.5.2)|python2-base
+Suggests: python-scons, python2-scons
+Description: An Open Source software construction tool script
+ SCons is an Open Source software construction tool--that is, a build tool; an
+ improved substitute for the classic Make utility; a better way to build
+ software.
diff --git a/debian/rules b/debian/rules
index 38f5a8b..4ff4659 100644
--- a/debian/rules
+++ b/debian/rules
@@ -34,26 +34,37 @@ endif
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp
+ rm -f build-stamp configure-stamp install-common-stamp
rm -rf build
find -name .construct -exec rm "{}" ";"
dh_clean
-install: DH_OPTIONS=
-install: build
+install-common: install-common-stamp
+install-common-stamp: DH_OPTIONS=
+install-common-stamp:
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
- python build/engine/setup.py install \
---install-purelib=`pwd`/debian/python-scons/usr/lib/python1.5/site-packages --no-compile
+ touch install-common-stamp
- python build/script/setup.py install \
---install-scripts=`pwd`/debian/scons/usr/bin --no-compile
+install-scons: build install-common
+ python build/scons/setup.py install \
+--install-scripts=`pwd`/debian/scons/usr/bin \
+--install-purelib=`pwd`/debian/scons/usr/lib/scons-0.01 --no-compile
+
+install-python-scons: build install-common
+ python build/python-scons/setup.py install \
+--install-purelib=`pwd`/debian/python-scons/usr/lib/python1.5/site-packages --no-compile
- python build/engine/setup.py install \
+install-python2-scons: build install-common
+ python build/python2-scons/setup.py install \
--install-purelib=`pwd`/debian/python2-scons/usr/lib/python2.0/site-packages --no-compile
+install-scons-script: build install-common
+ python build/scons-script/setup.py install \
+--install-scripts=`pwd`/debian/scons/usr/bin --no-compile
+
# This single target is used to build all the packages, all at once, or
# one at a time. So keep in mind: any options passed to commands here will
@@ -82,17 +93,20 @@ binary-indep: build install
binary-arch: build install
# Any other binary targets build just one binary package at a time.
-binary-scons: build install
+binary-scons: build install-scons
$(MAKE) ENVOKED_BY_CONSTRUCT=$(ENVOKED_BY_CONSTRUCT) -f debian/rules binary-common DH_OPTIONS=-pscons
-binary-python-scons: build install
+binary-python-scons: build install-python-scons
$(MAKE) ENVOKED_BY_CONSTRUCT=$(ENVOKED_BY_CONSTRUCT) -f debian/rules binary-common DH_OPTIONS=-ppython-scons
-binary-python2-scons: build install
+binary-python2-scons: build install-python2-scons
$(MAKE) ENVOKED_BY_CONSTRUCT=$(ENVOKED_BY_CONSTRUCT) -f debian/rules binary-common DH_OPTIONS=-ppython2-scons
+binary-scons-script: build install-scons-script
+ $(MAKE) ENVOKED_BY_CONSTRUCT=$(ENVOKED_BY_CONSTRUCT) -f debian/rules binary-common DH_OPTIONS=-pscons-script
+
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install binary-scons binary-python-scons binary-python2-scons
+.PHONY: build clean binary-indep binary-arch binary install binary-scons binary-python-scons binary-python2-scons binary-scons-script install-scons install-python-scons install-python2-scons install-scons-script
diff --git a/debian/scons.postinst b/debian/scons.postinst
new file mode 100644
index 0000000..34d87ab
--- /dev/null
+++ b/debian/scons.postinst
@@ -0,0 +1,27 @@
+#! /bin/sh -e
+#
+# postinst script for Debian python2 packages.
+# Written 1998 by Gregor Hoffleit <flight@debian.org>.
+# Modified for SCons 2001 by Anthony Roach <aroach@electriceyeball.com>.
+#
+
+PACKAGE=scons
+DIRLIST="/usr/lib/scons-0.01"
+
+case "$1" in
+ configure|abort-upgrade|abort-remove|abort-deconfigure)
+ for i in $DIRLIST ; do
+ python2 -O /usr/lib/python1.5/compileall.py -q $i
+ python2 /usr/lib/python1.5/compileall.py -q $i
+ done
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/scons.prerm b/debian/scons.prerm
new file mode 100644
index 0000000..0b62083
--- /dev/null
+++ b/debian/scons.prerm
@@ -0,0 +1,14 @@
+#! /bin/sh -e
+#
+# sample prerm script for Debian python2 packages.
+# Written 1998 by Gregor Hoffleit <flight@debian.org>.
+# Modified for SCons 2001 by Anthony Roach <aroach@electriceyeball.com>.
+#
+
+PACKAGE=scons
+
+dpkg --listfiles $PACKAGE |
+ awk '$0~/\.py$/ {print $0"c\n" $0"o"}' |
+ xargs rm -f >&2
+
+#DEBHELPER#