summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorGary Oberbrunner <garyo@oberbrunner.com>2012-08-13 03:25:31 (GMT)
committerGary Oberbrunner <garyo@oberbrunner.com>2012-08-13 03:25:31 (GMT)
commitfa19ee19b1048e25a8915c6e9c0c7bef11d28481 (patch)
treed623ba107f87296c3b7101d5d798e767125ba2f4 /debian
parent8a4cdff25c3e2f765c288bc7ef749343ccb7ff4a (diff)
downloadSCons-fa19ee19b1048e25a8915c6e9c0c7bef11d28481.zip
SCons-fa19ee19b1048e25a8915c6e9c0c7bef11d28481.tar.gz
SCons-fa19ee19b1048e25a8915c6e9c0c7bef11d28481.tar.bz2
Fix Debian build process.
Each release needs to update debian/changelog, and it needs to be in a particular format since the deb build process reads and parses it to get the version number in the .deb. Also fixed a few other deb-build-related errors.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/postinst2
-rw-r--r--debian/rules4
3 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 441f572..af58281 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+scons (2.2.0) unstable; urgency=low
+
+ * Maintenance release.
+
+ -- Gary Oberbrunner <garyo@oberbrunner.com> Sun, 12 Aug 2012 09:00:00 -0500
+
+
scons (0.97) unstable; urgency=low
* Eighth beta release.
diff --git a/debian/postinst b/debian/postinst
index ed8ed5c..6a7d335 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -7,7 +7,7 @@ if [ "$1" = "configure" ]; then
fi
NAME=scons
-PYTHON_VERSION=`python -V 2>&1| cut -d" " -f2 | cut -d"." -f0-2`
+PYTHON_VERSION=`python -V 2>&1| cut -d" " -f2 | cut -d"." -f1-2`
PYTHON_EXE_NAME=`which python$PYTHON_VERSION`
case "$1" in
configure|abort-upgrade|abort-remove|abort-deconfigure)
diff --git a/debian/rules b/debian/rules
index 1eaf4de..1effa02 100644
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,7 @@
# Overridable variables added to support building test .deb files
# as part of routine SCons builds. --SK
BUILDDEB_OPTIONS=
-PYTHON_VERSION=`python -V 2>&1| cut -d" " -f2 | cut -d"." -f0-2`
+PYTHON_VERSION=`python -V 2>&1| cut -d" " -f2 | cut -d"." -f1-2`
PYTHON_PATH=/usr/bin/python
PYTHON=$(PYTHON_PATH)$(PYTHON_VERSION)
#######
@@ -55,7 +55,7 @@ install: build
@########
mkdir -p debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/
rm -rf debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/SCons
- cp -r build/lib/SCons debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/
+ cp -r build/lib*/SCons debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/
mkdir -p debian/scons/usr/bin/
rm -f debian/scons/usr/bin/scons