summaryrefslogtreecommitdiffstats
path: root/gentoo
diff options
context:
space:
mode:
authorWilliam Deegan <bill@baddogconsulting.com>2017-09-18 15:31:20 (GMT)
committerWilliam Deegan <bill@baddogconsulting.com>2017-09-18 15:31:20 (GMT)
commitdee00005f2e4e1632213f68e6caaa71b2c93f9ed (patch)
treeb0770f6ea7c57b07b821833b1b40e19f8ae4b782 /gentoo
downloadSCons-dee00005f2e4e1632213f68e6caaa71b2c93f9ed.zip
SCons-dee00005f2e4e1632213f68e6caaa71b2c93f9ed.tar.gz
SCons-dee00005f2e4e1632213f68e6caaa71b2c93f9ed.tar.bz2
Regenerated docs for 3.0.0 release.
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/scons.ebuild.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/gentoo/scons.ebuild.in b/gentoo/scons.ebuild.in
new file mode 100644
index 0000000..50c9ad9
--- /dev/null
+++ b/gentoo/scons.ebuild.in
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $__NULL__Header: /home/cvsroot/gentoo-x86/dev-util/scons/scons-__VERSION__.ebuild,v 1.2 2003/02/13 12:00:11 vapier Exp __NULL__$
+
+MY_P=${PN}-__VERSION__
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Extensible python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.scons.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND=">=dev-lang/python-2.4"
+
+src_compile() {
+ python setup.py build
+}
+
+src_install () {
+ python setup.py install --root=${D}
+ dodoc *.txt PKG-INFO MANIFEST
+ doman scons.1
+ doman sconsign.1
+}